USB drive boot problem

I’m trying to create a bootable USB flash drive (mass storage device) using QNX4.25 and the QNX4.25 RTOS USB 2.0 Beta drivers. The problem I’m having is during the execution of the boot image upon booting off the USB drive. When the ‘io-usb’ command runs to create the USB stack, there is about a two second delay after the creation of the USB stack before the Fsys.umass driver can successfully recognize any connected USB devices. I’m able to create this delay using the ‘sleep’ command when I boot off the hard disk, but due to the round-robin scheduling done during the execution of the boot image, using the ‘sleep’ command is ineffective. The Fsys.umass driver has a command line option ‘umass wait=time’ that claims to force the driver to wait ‘time’ number of seconds for the USB stack, but this also doesn’t solve the problem. What I’d like is some way to delay execution of the Fsys.umass command despite the time-slice exuction performed as part of the round-robin scheduling of process execution of the programs contained in the boot image. Any help would be immensely appreciated. Thanks!

Im also interested in this. There is a beta newsgroup under your myqnx account where the one developing these drivers is answering questions, maybe you could try there.

The command “waitfor” should work. Make it to waitfor the usb device file to be created under /dev/.

Thanks for the suggestion, but the ‘waitfor’ command doesn’t exist in QNX4, only QNX6.

I’ve tried writing a utility to pause for a couple of seconds and then execute Fsys.umass, but it seg faults upon bootup every way that I’ve tried. Does anyone know if there are read/write restrictions on whatever memory the boot image is placed into?

I am finding usb drivers for QNX4, Somebody know where I download it?

As mentioned in the first post in this thread, you will need to join the QNX 4 USB 2.0 beta.

See below links for details: