QNX 2.0 and VM WARE 5.0


I installed QNX on VMWARE running on windows xp , i have configured the Virtual machine to directly read in from the floppy , parallel port. I have installed a IOMEGA ZIP250 on my parallel port, (BIOS: Bidirectional, IRQ7, Enabled) .

The QNX OS itself works fine, when i try to copy in files from the ZIP drive, the computer (the host) hangs, the computer does not respond to any operation other than turning it off.

Has anyone faced/solved any problems with VM Ware hanging up with QNX 2.0 on windows xp. Your help is greatly appreciated.


I don’t remember QNX 2 came with a Parallel ZIP driver. You must be using some 3rd party drivers? Have you talked to them?

Parallel port are not support in VMWare if my memory is serving me right. How exaclty are you performing the copy?

I have used VMware 3.2 in exactly this way, writing to and from a parallel port Zip drive. I run Windows XP Pro too. What Zip driver are you using? I use the driver from Mitchell Schoenbrun (mashoen@gmail.com)

However I recently had a similar problem with a PC running QNX 2.21 on a DX100 system. (No VMWare, it was a “real” installation). Having checked the BIOS (avoid ECP if you can, I had EPP 1.7) and the IRQ, the only change I made before I got it working reliably was to power off the zip drive when the computer booted. I’m guessing that the PC threw crap out of the parallel port when booting that screwed the connection. Try booting VMware, then connecting and powering up the Zip drive.

Are you mounting the driver manually or by some other means? Is it a Zip 100, Zip 250?

Do you have anything else running on the parallel port on the XP system? Printer drivers, for example? Is anything connected to the passthrough port?

Thanks for all the information, I am using Iomega p250 zip drive, I have used all the permissible BIOS setting but in vain. I have given up, my colleague was able to get his VMware working , he put up the entire proj on the N/W , we are sharing it up from there. I guess that solves most of the problesm

thanks for all the inputs,


Hi qnxlyser,
I am a colleague of AtlasMartin who gave you an earlier reply. I have had the same problems with XP and parallel ports - XP detects tha Zip drive, installs drivers for it and in doing so, grabs the parallel port so VMWare cannot use it. The solution I have found is simple - start VMware before you connect the Zip drive. Once VMWare has got it’s hooks in, XP cannot mess with the parallel port again.
Surprisingly, once VMWare has started and the Zip drive is connected, you seem to be able to exit VMWare with the ZIP still connected and it still works when VMWare is re-started.

I use VMWare 3 generally and this seems to do a better job of running QNX than VMWare 5? When I created a QNX machine under VM5, the first time that fdisk was run in the install, it reported a certain size of disk (524 MB) with about 800 cylinders. Subsequently, I ran fdisk again (to create another “disk” for backup purposes) and this time, it reported a disk of 322 MB with 526 cylinders! Which was doubly strange since the first partition finished at 800 cylinders!! VMWare 3 does not seem to suffer from this. Have you experienced anything like this?

Never had this problem. Hower I never created a disk with more then two partition, instead I setup to virtual HD, one with QNX, one with all my personnel stuff. Hence under windows all I need to backup is the virtual data disk.

As for zip drive and alike, I don’t bother with this stuff because I use networking to let QNX access most of Windows devices (USB key, USB CD, etc)


I’m very interested in how you do this. Could you please post or pm or email an outline for me?

Many thanks,