How to use a floppy disk under QN X6.3

Hi everybody,

just a simple question.

I try to mount a floppy drive for “qnx2” format and “dos” format to copy data to the hard disk. But I get bad luck.

My documentation is only for qnx 2.21 and do not fit in that matter with qnx 6.3. At this time, I only have a evaluation version without any documenentaion (o.k. online help). But I do not found help in this matter.

Even the faq do not answer this ?

Is there a link existing to a web side or a document, which explains commen used commands (actions) for qnx 6.3 ?

Best regards


How did you try to mount it? Did you log in as root?


I was log in as root!

Does mount work on other user that “root” ?

I tried the sample of the online help of the mount command.

’ Does mount work on other user that “root” ? ’
Not to me at QNX 6.2.1

mkdir /floppy
mount -t dos /dev/fd0 /floppy


mount -t qnx2 /dev/fd0 /floppy

It should work.

I don’t think QNX 6 supports the qnx2 filesystem. The above command will probably fail.
On the other hand, you can always use the dos format, which is supported by all versions of QNX.

Hello Noc,

you are right. The command for qnx2 will not work. I tried it. After reading the document again, i only found qnx 4.

But then i try to show the directory and failed again.

Under qnx 2 i used a drive id for the mount command.

How is this done in qnx 6 ? i would like to show the files in the "file manager to copy the file to the hard disk. Which will hopefully go with “CP”


also, is there a way to format floppy disks in qnx?


Uhm. ‘fdformat’ didn’t work fine at all to me. I had to use ‘dinit’ (after ‘fdformat’) and clear all floppy files later to really format the floppy into QNX4 file type.

If I just used ‘fdformat’ I could never mount the floppy. Do anybody know if I was doing anything wrong?

nothing wrong.
the fdformat utility formats the specified disk. formatting refers to a process of placing addressing marks and other control information on the disk to allow the hardware to read it. formatting does not imply any sort of filesystem structure. dinit does.
btw, if you try to acces a QNX formatted floppy disk in a WIN pc, WIN will actually lie to you saying that the disk is not formatted (should say “without DOS filesystem”). WIN also, when “formatting” a floppy disk, automatically installs a DOS filesystem on that disk.
maybe lack of tolerance, maybe only a matter of phraseology. until WINaa?? - but this is by memory from old times - there was a tool under WIN to “plain format” a floppy disk only, without any practical use.
regards HELGE

Thank you, WR :- >>