6.2.1 installer dies while booting

I got 6.2.1 downloaded and burned.

I’m trying to install it on a mongrel
system made up of assorted parts from
the mid-to-late 1990s: a motherboard
with on-board IDE (Acer chipset), a
Cyrix CPU, an ET6000-based VGA card,
and an Initio PCI SCSI controller.
The hard disk is on the IDE, the CD
on the SCSI. The system has 64M of
RAM, and is currently running Debian.

Possibly significant: it’s a 30Gig HD
on a BIOS with the 8Gig limitation.

I can start the boot process fine
from either CD or floppy. It prints
a bunch of progress dots (about 50
or 60 total), blanks the screen,
appears to be trying to start doing
something else (there’s just a tiny
fraction of a second of screen flicker),
then it’s back to the BIOS.

I’m guessing that my problem is unsupported
hardware, but it’s hard to tell from
the “diagnostic indicator” provided :smiley:

Any suggestions? I can try another PC,
but I hoped to get QNX running on this
one because it’s intended for my
headless server experiments.



It’s probably because of your SCSI CD ROM, it is old bug: it works from IDE to IDE or from SCSI to SCSI, but not from one to another. Can you try to connect IDE ATAPI CD ROM just for installing?

(A server hiccup ate my previous
attempt to post a reply, so I’m
skipping some details this time).

I tried borrowing the IDE CDROM drive
from my main PC to see if that would
get the Cyrix system going. No change.

I tried installing on my other old
system (a Pentium that runs off an
Adaptec 1542 SCSI controller). The
only difference is that the installer
hangs after printing out its progress
dots, instead of clearing the screen
and crashing.

Unfortunately, due to QNX’s partitioning
requirements, I can’t install it on
my main PC. So I’ve exhausted my
supply of Pentium-class machines, and
any 486s I built would be using
hardware that the installer has
already refused to work with (like
the SCSI drives).

Is there an unofficial method for installing
from a Linux box? Or, is it possible to run the Windoze-based
tools under WINE?



(Again with the “Invalid Session” errors. Sheesh…)

As mentioned in the follow-up I posted while you were
posting your reply, I did try putting
an ATAPI CDROM on cyril.

I also switched it to use SCSI for
both CD and HD, with no change.

Thanks for the suggestion,


Since I was doing peripheral transplant
surgery already, I pulled cyril’s
hard drive, hooked it up to my main
PC, got QNX installed (discovering
in the process that Photon really
dislikes my NVidia card: 640x480 only,
with 4-bit color.*), and reinstalled
it in cyril.

Where it promptly did the same “flash, bang”
trick that the installer did.

It also repeated the installer’s (slightly
different) misbehavior in the old Pentium

Guess I’ll just have to wait until I
can afford some different hardware


  • I was about to say “Shades of Windoze 3.1”,
    but I remembered that it supported
    8-bit color, so it had a lot more shades…

Yes, NVidia isn’t the best card for Photon. By default, it must be used vga video driver, and actually you can choose svga or vesa driver. Also, there is improved vesa driver which supports refresh rate above 60 Hz.
As for your old hardware, sorry, probably it has some problems and I have no enough information to think about it. I was able to run QNX6.0 on my old 386DX40 box, but of course I used custom image (without pci server, because there was no pci 2.0 bus, without diskboot, because I don’t know what it’s doing). There was article about (unofficial) installing QNX into logical drive, it was in Japanese, but it disappeared some time ago. There was discussion about unofficial way of installing (BTW, because there was same problem: scsi+ide), but it was in Russian and I’m not sure it is still exist in archive of russian forum. Anyway, you should try booting from CD (without installation) in verbose mode and find out the bad guy in your hardware or use this way learning QNX on your modern PC.

Unfortunately, my original problem
was that the boot process doesn’t get
that far.

Interestingly, the demo floppy works
on the Pentium box (but not the Cyrix).
So I think I’ll try to get 6.1 installed
on my main PC, and see whether I can
use that to bring up the Pentium (perhaps
with a network install).