Drivers for Network Card for QNX

I look for driver for network card Intel PRO/100 VM for QNX 6.2.1.

Is that a 82557/8/9 based card ? If so, try


Is that a 82557/8/9 based card ?
No it is not.

I tried the driver “devn-speedo”, did not work.

The network card is an ONBOARD, Mother board is 845GL chipset, I am using an “IBM Netvista A30 6824-52A”. The driver as seen in windows 2000 OS is “Intel PRO 10/100 VM”.

As per IBM specifications, it is mentioned as “Intel 10/100 Ethernet”.


According to my research, there is a 82562 nic on that chipset. According to Intel it is 82559 compatible; however, I am sure there are peripheral functions that are different. QSS will probably need to bring out an updated (although you may be able to get it to work by fiddling with command line options).

When can I get an update on, since i am not able to access the network.
Is there any other solution for network driver?

I am facing one more problem, when I mount /dev/fd0 i.e floppy drive the system starts accessing drive A: & hangs?
Why is this happening?
Can you tell me the process of how to mount floppy & Cd-ROM drives?

Actually, it is possible you just need to pass in the device id’s to the driver. The output from the pci utility should list your ethernet device. From that you will get a device id.

slay -f io-net
io-net -d speedo did=0xFFFF -p tcpip

Where FFFF is the device id you got from pci.

I have an integrated Intel PRO/100 VE NIC.

#io-net -d speedo vid=0x8086,did=0x1039 -p tcpip
command makes my NIC accessable from QNX 6.2.1NC

My problem is that I have to do it every time when I restart QNX.
How can I auto enable the interface using DHCP or fix IP address?

Any help would be appreciated.


Zoltan Sutto

echo "

slay io-net
io-net -d speedo vid=0x8086,did=0x1039 -p tcpip
waitfor /dev/socket
netmanager" >> /etc/rc.d/rc.local

chmod a+x /etc/rc.d/rc.local

I have a similar issue with the network chipset in my Sony TR2AP laptop.
io-net -dspeedo vid=0x8086,did=0x103d -ptcpip
works fine when typed in.
However, enum-devices does not find it, even though I have added:
device(pci, ven=$(PCI_VEND_INTEL), dev=103d) to the intel network section of
Should I be able to make this work ? is there another config file I also need to tweak ?

mucking around the /etc/system/enum/devices/net is probably not a good idea and your changes will get lost during an upgrade. It is suggested to use oem file, eg: you can create a /etc/system/enum/oem/sony_tr2ap and looks like this:

# /etc/system/enum/oem/sony_tr2ap
device(pci, ven=$(PCI_VEND_INTEL), dev=103d) 
append(legacy, ",nonet") 
uniq(netnum, devn-en, 0) 
mount(-Tio-net "-opci=$(index)" /lib/dll/, "/dev/io-net/en$(netnum)") 

# requires(@devn) 
waitfor(/dev/io-net/ip0, 5) 

Thanks for the help, I have it working now :slight_smile:

The mount line really needed to be:
mount(-Tio-net -o “vid=0x8086,did=0x103d” /lib/dll/, “/dev/io-net/en$(netnum)”)

From the command line, the following works:
dhcp.client -u

Where is a good config file to start dhcp.client in ?

Thanks !

I just added:
to the end of the same file and it works !

So I am really happy now :slight_smile:

starting dhcp.client works, but not the best way :slight_smile:
you should have configured your network interface using the GUI under Photon. You can set your network interface to use dhcp or static IP. Once you save it, the information will be stored in /etc/net.cfg file.

Now the

(last line in the oem file I posted above) will actually configure your network interface automatically based on your /etc/net.cfg. So if you have set to use dhcp, netmanager will start the dhcp.client for you. If you set to use static IP, it will “ifconfig” to set the correct IP for you.

I hadn’t been able to get the Photon Network Configuration to work before. It always seemed to be wanting to configure a dial up connection.
Just now, I clicked the right buttons and everything works. More experience like this and I might qualify to be trained as a Windows administrator :wink:
Anyway, thanks for all your help. It is appreciated, since this problem was quickly solved.

That was because of your NIC. Since there was no ethernet interface up, the GUI wouldn’t give you any related options :frowning:

Now that you’ve resolved that problem, GUI starts to work :slight_smile:

Please, help!
can’t get anywhere the driver for Intel PRO/100 VE ethernet adapter for QNX 4.25, adapter is integrated on Intel D815EFV chipset. Or may be some alternative exists?
Best, regards

Please, help!
can’t get anywhere the driver for Intel PRO/100 VE ethernet adapter for QNX 4.25, adapter is integrated on Intel D815EFV chipset. Or may be some alternative exist?
Best, regards

This is a QNX 6 group, maybe you should post your question in the QNX 4 one.

Older Intel pro/100 were supported by the Net.ether82557 or Net.ether82595. You might want to try it with your new adapter to see if you are in luck.