USB Keyboard & Mouse on a Dell


I’ve searched thru the forums here looking for info on USB keyboards and mice. There seems to be at least several dozen threads on getting things to work or not work based on 6.2.1, 6.3, SP1 etc. It’s all very confusing to look through and it’s too bad this site didn’t have a FAQ section where the latest info on certain topics like this could be checked for the best way to do something.

Here’s my problem.

We ordered some new Dell machines. These are Dell GX 280’s. Thanks to Dell’s cheapness on parts, these come with only USB ports (no PS2 inputs anyplace) for keyboards and mice.

So I tried to install QNX 6.3 on this machine. The install process starts up and I have keyboard control initially (that is I can press D to disable DMA or set other IDE driver stats). But the instant the install process reaches the press F2 to install QNX or F3 to run from CD-Rom I lose all keyboard control. I can no longer type anything.

So question #1 is, does QNX initially read the keyboard setting from the BIOS to give me initial keyboard control and then when the drivers start does it lose this mapping somehow???

To try to get around the problem, I installed 6.3 under Virtual PC. I then installed SP1. Then I ghosted the virtual PC image to the HD from the Dell machine. I put the HD back in the Dell machine and booted it up. I boot directly into the photon login screen where of course I have no keyboard or mouse control.

From this thread I went into the virtual PC image and did the following:

in /etc/rc.d/rc.local add:

io-usb -d uhci

In /etc/system/trap/input.$HOSTNAME

I add the following as a single line:
devi-hirun msoft fd -d/dev/usbmouse0 kbd fd -d/dev/usbkbd0

The I re-ghosted this image to the HD and put it back in the Dell machine. I re-booted and at the photon login screen I get a message saying it’s searching for devices. Is stays with that displayed forever and of course neither the keyboard or mouse work.

So question #2 is, is there something else I should he doing/trying to get the USB support working on the Dell. Or is the fact that it never worked either at install time or after trying to hand start the drivers mean that this model of Dell just isn’t supported in some way?



The issue of USB-only-keyboard Photon not working is known for a long time. It will hopefully be addressed with 6.4. In the meantime I think the only way to get around this is to build an own Photon script which starts the USB keyboard and mouse driver, similarly to what you did. However you have to remove the part that tries to start the PS2 keyboard and mouse driver. I’ve never done this though, so I can’t explain further.

I would suggest you “touch /etc/system/config/nophoton” and try to make it work in text console mode first before diving into Photon. You can then tweak the “/usr/bin/ph” script and run “ph” manually from the text console to test out.

Still working on the problem but have been busy taking care of other things and just got back to this.

I ended up pulling the drive out and placing it in a machine with a PS2 keyboard and mouse. I then edited the startup to enable inetd and IP support and touched the /etc/system/config/nophoton file.

I put the drive back in the Dell and waited till it booted up to the login prompt where everything is hung on the keyboard and mouse.

I telnetted into the box and did a ‘usb -v’ to get the following:

usb -v

USB 0 (UHCI) v1.10, v1.01 DDK, v1.01 HCD
Control, Interrupt, Bulk, Isoch, Low speed

USB 1 (UHCI) v1.10, v1.01 DDK, v1.01 HCD
Control, Interrupt, Bulk, Isoch, Low speed

USB 2 (UHCI) v1.10, v1.01 DDK, v1.01 HCD
Control, Interrupt, Bulk, Isoch, Low speed

USB 3 (UHCI) v1.10, v1.01 DDK, v1.01 HCD
Control, Interrupt, Bulk, Isoch, Low speed

Device Address : 1
Upstream Host Controller : 3
Upstream Device Address : 0
Upstream Port : 0
Upstream Port Speed : Full
Vendor : 0x413c (Dell)
Product : 0x1002 (Dell USB Keyboard Hub)
Device Release : r2.00
Class : 0x09 (Hub)
Subclass : 0x00
Protocol : 0x00
Max PacketSize0 : 8
Hub Number Ports : 3
Hub Characteristics : 0x000d (Individual power, Compound, Individual over
Hub Power On->Good : 100 ms
Hub Power Requirements : 90 mA
Configurations : 1
Configuration : 1 (Dell USB Keyboard Hub)
Attributes : 0xa0 (Bus-powered, Remote-wakeup)
Max Power : 90 mA

Device Address : 2
Upstream Host Controller : 3
Upstream Device Address : 1
Upstream Port : 1
Upstream Port Speed : Full
Vendor : 0x413c (Dell)
Product : 0x2002 (Dell USB Keyboard Hub)
Device Release : r2.00
Class : 0x00 (Independant per interface)
Max PacketSize0 : 8
Configurations : 1
Configuration : 1 (Dell USB Keyboard Hub)
Attributes : 0xe0 (Self-powered, Remote-wakeup)
Max Power : 0 mA

Device Address : 3
Upstream Host Controller : 3
Upstream Device Address : 0
Upstream Port : 1
Upstream Port Speed : Low
Vendor : 0x046d (Logitech)
Product : 0xc016 (Optical USB Mouse)
Device Release : r3.40
Class : 0x00 (Independant per interface)
Max PacketSize0 : 8
Configurations : 1
Configuration : 1
Attributes : 0xa0 (Bus-powered, Remote-wakeup)
Max Power : 100 mA

I don’t know much about USB but it looks to me like it sees the mouse and keyboard. So I am mystified why neither appear to work. Is is because I am plugged into the wrong USB ports and QNX expects me in USB 0 or USB 1?

Note, devi-hirun fails when run from a telnet session complaing about not being able to find photon. So I need another way to actually do the mappings for console control. Any ideas?


OK. I finally got the USB support up and running correctly on my Dell box.

In the interests of anyone else trying to get a USB keyboard/mouse only PC running I’ll present the following solution I ended up with.

  1. QNX 6.3 with SP1 installed

In rc.local I added the lines

io-usb -d uhci
waitfor /dev/io-usb/io-usb

In /usr/bin/ph script I added the lines (starting at line 128):

/sbin/io-hid -d usb &
sleep 2
/usr/photon/bin/devi-hid kbd &
/usr/photon/bin/devi-hid mouse &


  1. I was never ever able to get USB working with devu-mouse and devu-kbd.

  2. This solution ONLY works under photon. I have no idea what the equivalent USB drivers are under console mode for devi-hid

  3. I’m not sure starting the drivers in the ph script is the best place or even the right line number area but it works for me. I’m open to other suggestions.

  4. In order to get all this editing done, I needed to install on either Virtual PC or another PC with PS2 capabilities to make these edits. In fact the ability to get inetd running and telnet in proved to be the way I got the final solution as I was able to try and test things until I found a working solution.



so you had the same problems as I have…
if you look at my thread under
Forum Index » General » QNX Newsgroups » qnx.newuser
you can see i exactly did the same as you only without writing it into the ph-script. I made my keyboard working that way but my mouse still doesn’t work:
after typing devi-hid -vvv mouse & into the photon terminal
the following message is returned:
[1] 938026
#Looking up mouse in module table
Resetting module mouse
Resetting module rel
Input: start Photon interface
Device insertion: device instance = 8060068, device no = 0
interrogate bus, returning rel
Device insertion: device instance = 8060090, device no = 1
Attach mouse report
but my mouse is not working
Did I forgett anything???
Can you help me???

And if you have a solution to make the mouse and the keyboard working in console mode, please tell me!!!



Is there anybody, still thinking about my problem???
I yet didn’t make it…and I am still searching for a solution!!

The only thing I recognized is, that the cursor shortly appears on the screen after typing devi-hid -vvv mouse &, but immediately disappears again without being movable.

Please give me a solution, or even an idea, what else I should try!!!

Thanks for the moment…


Sorry for a late reply here. I haven’t logged in to the board in a while so I didn’t notice your posting till today.

First. I don’t use console mode so as I said, I never attempted USB support under console mode, only under photon.

I looked again at my edit to the /usr/bin/ph script and I have modified it slightly over time to shorten it and to get the keyboard repeat to something more manageable.

It now looks as follows:

/sbin/io-hid -d usb &
sleep 2
/usr/photon/bin/devi-hid kbd -k1,500 mouse &

That works just fine on my Dell box and Dell USB mouse.

The first thing I would do is to make the same edit I did and see if that works. I don’t remember all my details from that time but I think I added where I did because Photon will start some default drivers for PS/2 if the USB stuff is not started.

At least then you get to the same point I did and if that fails to work for you then you know it’s something hardware related to the PC, keyboard, mouse or both (tho I think you have the keyboard working now, correct?).

Also in your other post you mentioned not seeing a /dev/kbd entry. That’s strange because I definitely have a /dev/kbd entry on my machine using USB.

We have different results when I type ‘pci -v’ in terms of the details on our USB controller (I have same vendor ID of Intel but the rest of the stuff is different). Mine is the crappy Dell USB 1.0 which may be different if you have 2.0