QNX 6.2.1nc and VMWare

Hi, i’ve installed QNX 6.2.1nc under the VMWare software.
The installation it’s end without problem but when I start QNX I’ve this error message:
Shutdown[0,0] S/C/F=11/1/11 C/D=f00129b6/f0046ec0 state(c0)= now lock


I’ve attached the complete error report.

There are some people who have installed QNX 6.2.1 under VMWare?

If I boot from cd always under VMware i’ve the same error.

Thank’s you in advance


PS The other S.O. (Linux, Windows) run without problem under VMWare.

Hi. It’s VMWare problem, not QNX :slight_smile: Report this to them :slight_smile:

I’ve seen lots of people having success with VMWare4 and QNX 6.2.1, though you have to use the svga driver and the graphics is very slow.

Thanks Dave for his article:

Here is what I posted in another group which should give you some more details regarding the graphics issue:

[size=150]Just reject all permitions to file: /sbin/enum-pnpisa

No point in doing that QNX is not on VMWare’s list of support OS.

hey, that’s a great trick!
I just tried renaming enum-pnpisa to something else and vesa driver is now working! I didn’t know the vesa driver actually uses /sbin/enum-pnpisa which caused the crash of vmware …

During the initial QNX install into VMWARE, at the first reboot, you could press ‘space’ > F11 > disable enumerator for pnpisa and this will get you complete the 2nd stage of QNX installation successfully.

vesa driver is definitely faster than svga one.

Thanks again to Ravity for the great tip!

I’ll run a test and update the article

you might as well suggest that for people that can’t get the mouse working for example, they could use phindows run photon session in VMWare, it will actually runs faster then when vesa driver is used, mostly if you have an SMP machine!!!