Photon on Toshiba laptop

I’ve got problems with stability of Poton 1.14A (the most recent version
AFAIK) running QNX 4.25D on Toshiba Satellite Pro 4300 series. The
graphics controler - S3 Savage/IX-MV rev 17 with 8MB RAM, 14’ TFT
display, 128M ram.

What’s wrong? Photon works very well with Pg.flat* drivers, but every
time, when I do some window operations (moving, resising, etc.) screen
unexpectedly freezing. What interesting, all time I see in that moment
only a half of cursor and Photon sems to be running in the background -
when I change virtual console, start pterm (Alt_Ctrl-2, Alt-Enter, S)
and type “slay Photon”, system returns to text mode.

The same problems appears on two identical machines. Previously I worked
on the same model, with the same savage chipset, but with 13’ DSTN
display and max resolution 800x600 and Photon worked fine.

crt.node first line: -S -i0x4117 -s0x0001,0x0000 -r;Pg.flatdc -HC0x00010000
-HNqnx/crt -g1024x768x16 -A0xF0000000,0x800000
-WB2048;#1024,768,16,100,1,flatdc - VGA hi-color

BTW - QNX RTP and XFree 4.0.2 on Linux works very well :slight_smile:

Any suggestions?

Arek Benes