Using phditto to see a running Photon session

I have searched the archives and didn’t see it.

I have a PPP connection to a remote QNX 6.1 system (mine is also QNX 6.1). If I do
‘phditto -t <ip_addr>’
I get a Photon login window, so I know it basically works, but that’s not what I want.

There is a Photon session already running on the remote system, and I want to see its display. The answer may be in the help file, and I don’t know how to interpret it. It seems like -n might be the thing, but when I ran this:
‘phditto -t <ip_addr> -n /dev/photon’
the connection failed. /dev/photon is on the remote system - is that the correct way to look at this?

Do I perhaps need to specify the user under whose ID the photon is running? I’ll try that while the experts mull over this.

What else do I need to do?

Randy C.

To follow up my own posting…

I can execute a PhLogin to the remote system as a different user, and I get a nice, complete, functional Photon desktop. No problem there.

If I try to use the -n option, and give the /dev/photon file that I can see there, the window starts, displaying the comments. I get:


and the window goes away.

What am I doing wrong?

Randy C.

I am not really shure if I understand your problem (my native language is German), but have you tried :
phditto -h715 -w1007 -x1024 -n/dev/ph+ -o1 -t10.0.0.19 -U[userid] -s[service]

there is also a more explanatory WINDOWS help file available. it came with the phindows software and deals with that one, but is more detailed than the online “utilities reference”, to my taste. I will mail it to you, if you can find a WINDOWS box somewhere to read it ;-)

regards HELGE

Sorry I get so scattered (and then this site was down for a few days). So I’ve been slow to respond to this.

I did get phditto to work. I needed to specify the remote device file, and I was not doing it correctly.

Thanks for the suggestions - they definitely helped lead me in the
right direction.

Randy C.