6.2.1 No Mouse Cursor

I always need to boot up in safe mode as qnx hangs when “detecting input devices.” Tried using USB and PS2 mouse - same problem. Have a GE FORCE MX2 graphic card.

Does 6.2.1 even support USB mice?

Can start Photon in safe mode and use the keybd to move around. Have read several posts about inputtrap but the command does not return a text string.

If you have some suggested instructions, please be very specific about how to proceed as I am a LINUX/QNX neophyte.


please use the search function of the forum, the usb mouse problem was discussed several times, e.g.

i need QNX Momentics Professional V6.2.1A download not for windows version
please help me how i can find i

You can ONLY download the QNX 6.2.1 Non commercial (NC) version. The professional version is not available for free download. You will have to contact QNX for purchase.

If you are ok with the limited NC version, check the comments in this post for download links.

I am getting much the same behaviour, except that once or twice the mouse and keyboard worked for a little while and then “froze”. If I figure out an answer I’ll post it. Anyone else?

I appear to have this sorted now, but I’m running 6.3.0 - apologies for any earlier confusion.

The final fix (as suggested by earlier threads):

rc.sysinit (after the waitfor function):
io-usb -d ohci -d uhci -d ehci &
waitfor /dev/io-usb/io-usb
io-hid -d usb &
waitfor /dev/io-hid/io-hid

/usr/bin/ph (after line 128: if [ $xphoton = 1 ] ; then)
/usr/photon/bin/devi-hid kbd &
/usr/photon/bin/devi-hid mouse &

Prior to all this, using only a USB keyboard, the whole machine would freeze (unresponsive to telnet session, ping, etc.) after a few minutes. Plugging in a PS2 keyboard would unfreeze everything, and then the USB keyboard worked fine in console mode.

All in all this is NOT the friendliest possible start to a relationship with a new OS!

Nobody is twisting your arm to make friend with it, at least I hope not!