problems while installing Phinx

I found this posting on the qdn. It may be helpful
for people here who wants to install phinx from


– forwarded message –
From: Andrew Thomas <andrew=I06DRU8f8swbkApDdU+tqQC/>
Newsgroups: qdn.public.qnxrtp.installation
Subject: Re: Dependencies problems while installing Phinx
Date: Thu, 30 May 2002 10:35:11 -0400
Organization: QNX Developers Network (

Here’s how it’s done…

Create a directory - I named mine /usr/X11R6.6.1/lib
and put the following libraries and directories from a 6.1
installation into it:


I have made no effort to determine how many of these libraries
are actually necessary. Notice that and
both came from /lib, not from /usr/X11R6/lib.

Copy the file /usr/lib/ from a 6.1 installation into
the /usr/lib directory.

Install the phinx package. When it takes you to the “missing
dependencies” screen, click the install button quickly to go
on and install the package in disabled mode.

Edit the file: /etc/system/package/packages
and add the line


above the existing line


Start the odl package manager and use the file menu item
“Restart the package filesystem”.

Create a shell alias or a shell script (I named mine “phx”)
like this:

alias phx=‘LD_LIBRARY_PATH=/usr/X11R6.6.1/lib /usr/photon/bin/phinx
-geometry 1020x744+0+0’

Now to run phinx, use the phx alias.


– end of forwarded message –