[iso-8859-1] Réf. : Re: [Openqnx-deve loper] ddd doesn't rec

sounds like your fs is corrupted.

btw, my understanding is no one is using libc.so directly. it is
preloaded from the boot image directly. cdm, any comments?


---------- Forwarded message ----------
Date: Thu, 27 Jun 2002 07:58:53 +0200
From: alain.bonnefoy=uWxFhhn2E0U@public.gmane.org
To: Frank Liu <liug=wJsaexb6DEQ3G7qi5jAxu4dd74u8MsAO@public.gmane.org>
Subject: [iso-8859-1] Réf. : Re: [Openqnx-developer] ddd doesn’t
recog[iso-8859-1] nize libc !?

I’m running 6.1 with xfree4.2
I use it remotely with vnc.
I got the lasts packages from sourcforge.

Everything worked perfectly some weeks ago and ddd began suddendly to have some
problems with remote debugging.
I use to execute ddd on my qrtp server, more powerfull, to debug my apps on a
pentium 166 target.
When I enter the command “target qnx ip_address:port”, inetd start pdebug, but I
haven’t any answer from pdebug in the gdb console. I don’t really remember the
message I should have, something like “remote debugging…”.

I don’t know why, any idea?

Then, a second problem appeared; since the beginning I had to execute ddd as
root to prevent the message “libc.so.2 not in executable format” when I tried to
run program in ddd, but now I get this message even if I execute dd as root.

Do you have the same problem if you execute ddd without root’s privileges? why?

Thanks a lot.

Frank Liu <liug=wJsaexb6DEQ3G7qi5jAxu4dd74u8MsAO@public.gmane.org> le 26/06/2002 08:41:44

Pour : openqnx-developer=5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f@public.gmane.org
cc : (ccc : Alain BONNEFOY/Valence)

Objet : Re: [Openqnx-developer] ddd doesn’t recognize libc !?

are you running qnx6.1 or qnx 6.2?
are you running native XFree86, old Xphoton, or new XPhoton?
are you on the qnx console or running it remotely?
has the ddd 3.3.2-2 ever worked for you?
if so, what has changed since then?


On Tue, 18 Jun 2002 alain.bonnefoy=uWxFhhn2E0U@public.gmane.org wrote:

I encounter some problems since few days with ddd 3.3.2-2.
everything worked at the beginning except that I had to run ddd as root to
prevent the message about libc (I’ll talk about it later).
My problems began later with the impossibility to debug on a remote target.
No answer to the command ‘target qnx ip_adr:port’ from the target despite
is launched correctly.

Now, everytime I want to debug a program, I get the following message:
libc.so.2: not in executable format: file format not recognized.

As I said, I could prevent this message by running ddd as root. but now, that
doesn’t help me anymore!

If I use gdb only, there is no problem.

Any idea?


Bringing you mounds of caffeinated joy

openqnx-developer mailing list
openqnx-developer=> 5NWGOfrQmneRv+LV9MX5uipxlwaOVQ5f@public.gmane.org

This sf.net email is sponsored by: Jabber Inc.
Don’t miss the IM event of the season | Special offer for OSDN members!
JabConf 2002, Aug. 20-22, Keystone, CO http://www.jabberconf.com/osdn