Problem installing QNX 6.3.1


I have the following problem when I try to install QNX 6.3.1. It ask for me to enter a license key for installing. Ok, I use the license send by QNX to me and… it fails, QNX says the license key is not valid or out of date. But the license key is valid until 2005-11-26. I wrote to QNX commenting the problem and they told me is a problem with the date of my bios. But I tried to change it and the issue persists, so I cannot install QNX.

Does anybody has any idea about what is happening? Or does anybody where I can get another valid license key?

This discussion talks about the license key and the BIOS date, check to see if it helps.

I’m desperated. Yesterday I have downloaded again the QNX 6.3 iso CD and a new license key was sent to my email. However I have again the same problem, when I enter tje license key QNX says me is not valid or out of date.

Could anybody tell me what is happening? Also I have tried to modify the date in the bios, but the problem persists.

The email sent by QNX yesterday to me is the following (I’m not write the license key):

This email together with the license key below is your proof of license for the QNX software product identified below. It authorizes use of QNX® Momentics® Professional Edition - Evaluation (6.3.0) on one Workstation until the expiry date specified below under the terms of the applicable QNX Momentics End User License Agreement (see or contact QNX Software Systems to obtain a copy. Please note, you may not install or use the software if you are unable or unwilling to accept the applicable end user license agreement terms.

After the expiry date, you may either purchase a commercial license, or you may continue using the unlocked portions of the QNX Momentics Development Suite (along with the components of the QNX Neutrino® RTOS normally provided in binary form with the QNX Momentics Development Suite) under the terms of this Agreement, provided that such use is limited solely to: (1) use for Non-Commercial Purposes; and (2) use in a self-hosted (QNX Neutrino RTOS hosted) development environment targeting x86 processors.

Expiry Date: 2005-12-17

ATTENTION: To update your evaluation software to the latest version, you mustfirst register the following serial number and password to your myQNX account(login at

Online Product Registration
Serial Number: 904048-XXXXXXXX
Password: XXXXX

Once you have registered your evaluation serial number to your myQNX account host-specific Service Pack 2 (SP2) update to QNX Momentics 6.3.0 ( Download Center > Products & Updates > QNX Momentics > QNX Momentics 6.3.x ). SP2 is a major update that introduces significant new functionality and dramatically improves ease-of-use, reliability and performance of the tool suite.

If you require assistance or technical support for the product evaluation,visit news://

Thank you,

QNX Software Systems

I think all is clear. I copied the license key, but when I enter it on the QNX setup it tells me is not valid or out of date.

I have reviewed the posts about similar issues with the license key, but I don’t find any response to this problem.

hm, someone else seems to have the same problem:
Let’s see what QNX Support ( ) says.

I faced the same problem, this is what I did
a. download qnxwincleanup.exe … amid=19612.
b. Followed clean up instruction. However, it still did not work.
c. Finally copied the file qnxwincleup.exe at C:\Program Files\QNX Software Systems\license and tried installation again. It worked.

I did step (c) after reading in one of the post that QNX installer copies it to the above folder if available . I do not know if this the reason, any case it is working now.