modem installation

I have 2 identical qnx 2 machines with 2 usrobotics sportster internal
modems (model 0236 is the only identification I can find on the card). I
have a serial mouse on com1. There is an application that runs that resets
the configuration of $term1, so I have to use $term2 for the modems.

I have the bios set as:

serial port 1: com1, 3f8 irq4
serial port 2: com2, 2f8 irq3

plug and play: irq5 set for use by ISA card (I also tried it set to:

I have the modem jumpered for com3, irq5

stty to set up $term2 in sys.init:
stty baud=9600 bits=8 par=none stop=1 >$term2
stty esc=0 up=a1 down=a9 right=ab left=a4 ins=ab del=ac >$term2
stty +hflow +iflow +oflow +split >$term2
stty intcp=4,5 inton=5 in sys.init

osconfig looks like:
3f8 2f8 280 288 290 298 2a0 2a8
2b0 2b8 3e8 2e8 000 000 000 000

mount shows
$tty4=$term1 Serial at 02f8
$tty5=$term2 Serial at 03e8

Then I run: 3:/qterm/qterm m=$term2 p=3:/qterm/phone.dbase

My problem/question is: when I go through the dialing directory and try to
call, nothing happens, and qcl is reply blocked on dev. If I change the
modem to use irq 3 (chaning nothing else), it works fine - I see the
ATZ/OK/ATDT etc on the screen and the call is established.
I am not sure why the serial mouse still works - I would think that using
irq3 for the modem would cause a conflict.

Actually, only one of the cards works like this on only one of the
machines - moving this card to the other machine does not work. Neither
does the other card (with the jumpers set identically) in either machine.

Of course I dont have the user manual for the modems. I am not sure what
the 8 switches do. They are set to
1 2 3 4 5 6 7 8
off off on off on off off on

Any help will be greatly appreciated.


Nevermind… I figured out what was wrong. The serial mouse that I had
running on serial port 1 using COM1 was apparently using IRQ5. I had to
explicitly specify int=4 in the mouse driver command line (along with the
+com1) to get the modem to work with IRQ5.