network interface card problem

I had a network interface card (pcmcia / 3com 3c589) which used to run perfectly under win98 and qnx 6.2.1
just recently I discover I am not able to acces my LAN any more, this happens only under qnx.
phlip shows no device.
I slay io-net and restart it with the parameters I take from the time when the nic still worked.
I get the message :
“unable to init dll devn-el589 : Operation not permitted”

when I run qnx 6.2.1 from the CD, phlip shows a device and I can acces my LAN.

funny enough, the manufacturing dates of (for example) io-net and are different in the CD and the qnx I installed from the very CD. I wiped the harddisk, and installed qnx again, problem remains.

any help would be appreciated.
thanks HELGE

Is it possible something change in your BIOS to affect the PCMCIA controler.

no, unfortunately not.
the BIOS configuration offers very few parameters only, and PCMCIA is not listed. apart from that, the card was running for 3 years now (I have four of them, same model, and all of them the same problem), and I never touched the BIOS for months.
furthermore, the NIC is detected when I start QNX from the CD … and it works fine under WIN.

The QNX 6.2.1 CD is actually running QNX 6.2.0.
When you do the installation to hard disk, it will first install 6.2.0 and then
at the second stage of install (after a reboot), the installer will install QNX 6.2.1 packages (upgrade files) from the CD to “upgrade” the system to 6.2.1.
This explains why the CD runtime has some stuff different from the final 6.2.1 hard drive.