Service Pack 2 and inetd problem

I installed SP2 and ported my QNX System Builder project to the new IDE.
My QNX image is based on the mpc8540ads BSP.
I also installed the patch for the new TCP/IP stack [Patch ID 97].
Everything works fine except inetd which exits just after been launched with “exit status 0”.

I looked in documentation and didn’t find any difference between SP1 and SP2 for inetd.

I tried different options, here are the results:

inetd → nothing happen, no error message, no inetd in pidin output
inetd -d → nothing happen, no error message, no inetd in pidin output
inetd & → “exited with status 0”
inetd -d & → “exited with status 255”

/etc/inetd.conf, /etc/services and /etc/passwd are the same as with SP1

The rest is working normaly; qconn, my applications, …

Any idea :question:


You should check that the filesize is correct for inetd? The first inkling that something was not quite right with an image of ours which we upgraded to SP2 was that random stopped working and started giving meaningless messages when it failed. The file sizes did not match the expected file sizes when we checked them.

I checked the size of inetd and I didn’t see any problem. I also tried to copy it manually while the target system is running, then I tried to start it. There is no difference, inetd always exits :frowning:

Have you checked that the necessary libraries are available in your image using ldd ?

ldd <full_path_to_executable>

Should tell you which libraries it requires.

Other than that, we have had no problem using inetd under SP2 with our images.

Everything is working fine now. The problem was that config files were in DOS format instead of UNIX.
SP2 is installed on a new computer, and when I copied the project the config files were switch to DOS format. It seems that Visual Source Safe is not handling such subtilities.

You can tell VSS to no convert file format. I don’t recall the option, it has do be manually done in the config file, google it up.