Need help on compliling MPlayer on QNX 6.2.1A

Hello, every body!
I tried to compile the MPlayer -1.0pre7 on my QNX 6.2.1A, but it failed to success.
My QNX has installed the following software from qssl-third-part-cdrom:
GNU autoconf
GNU automake
GNU glib shared library/glib
GNU gtk shared library/gtk
GNU libtool
GNU m4
Simpale DirectMedia Layer/Simpale DirectMedia Layer Development
XFree86 pacakge include XPhoton

Install procedure:

  1. First, I typed “./configure”
    The result shows that my C compiler is not fit . It should be gcc-2.95.x or gcc-3.x, but mine is 2.95.3qnx-nto
  2. Then I tried “./configure --diable-gcc-checking --cc=gcc”
    After a warning on C compiler ,the configure procedure was successfull.
    I typed “make”, after a long time an error screen dispalyed. I copied the end part of the error information as followed!
    error: information:
    make[2]: Leaving directory /root/MPlayer/MPlayer-1.0pre6a/liba52' make[2]: Entering directory /root/MPlayer/MPlayer-1.0pre6a/libmpeg2’
    gcc -MM -I…/libvo -I…/…/libvo -fno-PIC -O4 -march=i686 -mcpu=i686 -pipe -ffa
    st-math -fomit-frame-pointer -I. -I…/libvo -I… -DMPG12PLAY alloc.c cpu_accel
    .c cpu_state.c decode.c header.c idct.c motion_comp.c slice.c idct_mmx.c motion_
    comp_mmx.c 1>.depend
    make[2]: Leaving directory /root/MPlayer/MPlayer-1.0pre6a/libmpeg2' make[2]: Entering directory /root/MPlayer/MPlayer-1.0pre6a/libfaad2’
    gcc -MM -I. -I…/libvo -I…/…/libvo -fno-PIC -O4 -march=i686 -mcpu=i686 -pipe
    -ffast-math -fomit-frame-pointer bits.c cfft.c common.c decoder.c drc.c error.
    c filtbank.c hcr.c huffman.c ic_predict.c is.c lt_predict.c mdct.c mp4.c ms.c ou
    tput.c pns.c ps_dec.c ps_syntax.c pulse.c rvlc.c sbr_dct.c sbr_dec.c sbr_e_nf.c
    sbr_fbt.c sbr_hfadj.c sbr_hfgen.c sbr_huff.c sbr_qmf.c sbr_syntax.c sbr_tf_grid
    .c specrec.c ssr.c ssr_fb.c ssr_ipqf.c syntax.c tns.c 1>.depend
    make[2]: Leaving directory /root/MPlayer/MPlayer-1.0pre6a/libfaad2' make[1]: Leaving directory /root/MPlayer/MPlayer-1.0pre6a’
    gcc -c -I…/libvo -I…/…/libvo -fno-PIC -O4 -march=i686 -mcpu=i686 -pipe -ffas
    t-math -fomit-frame-pointer -I. -I/opt/include/SDL -o mplayer.o mplay
    mplayer.c:193: eof' redeclared as different kind of symbol /usr/include/unistd.h:445: previous declaration of eof’
    make: *** [mplayer.o] Error 1


SO has anybody successed in compiling the mplayer on QNX or know what is on earth going on here!
I would be very appreciate if you can help me!!^_^!!!
My email is, thx!