DDK installation/Make problems


I just installed QNXRTP and the DDKs. I tried to do a ‘make’
on a directory, but it failed when it tried to create a file… I looked
the directory and it had problems being written to.

I tried to change its perms from drwxrwxr-x to 777 but it
persistantly refused (I was su). I am runing RTP on
a dos partition of an NT system. And I downloaded the DDKs
from Internet on a Windows machine on floppies and then loaded it to
my QNX machine using package mgr.

Then I tried to delete the directory (rm, rm -R, rmdir, unlink, mv and file
and that failed too. How can I forcefully delete a file? What is the
cause of this problem? How can root (or su) not be able to delete
or unlink a file?

Later I noticed that the file I am looking into is a link to another file:

ls -ai *

5144029 . 5144001 …

5144030 . 5144001 …

find / -inode 5144030 -print


find: Cannot recurse into ‘/pkgs/base/qnx/ph/pkginst-2.0A’ -
filesystem forms an infinite loop

How is this filesys infinit loop being created? How can I fix it?

When I changed the perms on the link (second line), then it permitted me
to change the permissions on the file I wanted to (the first line).

Q:Why have these guys been installed as owned by
root with no write perms for others… Or should I do the
simple ‘make’ (and not the ‘make install’) as root??

When I change the perms on X86 (or X86/a,…) to 777, I expect that I
should be able to create a new file in that directory, but I can not!
Only su (root) can create a new file there??? Why? Are we missing
a setuid bit somewhere?

And ‘make’ from a non-su fails because it still cannot
create files in that directory.

More info:

$ mount
/pkgs/base/qnx/ph/pkginst-2.0A on / type pkg <-----
/fs/hd0-dos-2/program files/qnx/boot/fs/root.qfs on / type qnx4 <----
/pkgs/base/qnx/ph/runtime-2.0.1 on /usr/photon/font type pkg
/fs/hd0-dos-2/program files/qnx/boot/fs/qnxbase.qfs on /pkgs/base type qnx4
/dev/hd0t6 on /fs/hd0-dos-3 type dos (fat16)
/dev/hd0t6.1 on /fs/hd0-dos-2 type dos (fat16)
/dev/hd0t6.2 on /fs/hd0-dos type dos (fat16)
/dev/cd0 on /fs/cd0 type cd (rrip)

How come there are two things mounted on / ?
Is this causing the problem? Who is doing this mount?