Porting Apache2

The posted Apache2 code has a problem with CGI, so I thought that I’d
download the latest from www.apache.org and play around with it.

The first problem I’ve encountered is with the configure script which
seems to barf because it it has a variable ${CC-cc} which is not set
anywhere. Does anyone know how to resolve this problem?



Mitchell Schoenbrun --------- maschoen@pobox.com

Mitchell Schoenbrun wrote:

The posted Apache2 code has a problem with CGI, so I thought that I’d
download the latest from > www.apache.org > and play around with it.

The first problem I’ve encountered is with the configure script which
seems to barf because it it has a variable ${CC-cc} which is not set
anywhere. Does anyone know how to resolve this problem?

Isn’t that the shell syntax for "The contents of variable $CC if
defined, else “cc”?

Previously, Norton Allen wrote in qdn.public.qnxrtp.porting:

Isn’t that the shell syntax for "The contents of variable $CC if
defined, else “cc”?

Maybe, but sh is returning NOTHING for this variable. I don’t know if
this is a problem with the QNX shell, or whether the script itself is
deficient.

Mitchell Schoenbrun --------- maschoen@pobox.com

Mitchell Schoenbrun wrote:

Previously, Norton Allen wrote in qdn.public.qnxrtp.porting:

Isn’t that the shell syntax for "The contents of variable $CC if
defined, else “cc”?

Maybe, but sh is returning NOTHING for this variable. I don’t know if
this is a problem with the QNX shell, or whether the script itself is
deficient.

I tried this in the shell, and it works as advertised. If CC were defined
elsewhere to be an empty string, that would explain the result you’re
getting. Try the following interactively:

unset CC
echo “’${CC-cc}’” # should give you ‘cc’
CC=’’
echo “’${CC-cc}’” # should give you ‘’

So perhaps you need to be looking further back in the script to see
what is setting CC to nothing.

Previously, Norton Allen wrote in qdn.public.qnxrtp.porting:

I tried this in the shell, and it works as advertised. If CC were defined
elsewhere to be an empty string, that would explain the result you’re
getting. Try the following interactively:

unset CC
echo “’${CC-cc}’” # should give you ‘cc’
CC=’’
echo “’${CC-cc}’” # should give you ‘’

So perhaps you need to be looking further back in the script to see
what is setting CC to nothing.

It is not set in the scripts anywhere. That suggests that on other
Unix like OS’s that these variables are available as defaults from
the shell. Is that so? Is the QNX shell deficient in some manner
because of this, or am I missing something?


\

Mitchell Schoenbrun --------- maschoen@pobox.com

Mitchell Schoenbrun <maschoen@pobox.com> wrote:
: Previously, Norton Allen wrote in qdn.public.qnxrtp.porting:

:> I tried this in the shell, and it works as advertised. If CC were defined
:> elsewhere to be an empty string, that would explain the result you’re
:> getting. Try the following interactively:
:>
:> unset CC
:> echo “’${CC-cc}’” # should give you ‘cc’
:> CC=’’
:> echo “’${CC-cc}’” # should give you ‘’
:>
:> So perhaps you need to be looking further back in the script to see
:> what is setting CC to nothing.

: It is not set in the scripts anywhere. That suggests that on other
: Unix like OS’s that these variables are available as defaults from
: the shell.

No.

: Is that so? Is the QNX shell deficient in some manner
: because of this, or am I missing something?

You are obviously missing something.
CC is probably override in src/Configure.

I did a quick port of apache, for 6.0 a few months back
and it did need a few harm twisted here and there from
the configuration. On the top of my head, I can remember :

  • that the src/helper/GuessOS was wrong. The default was
    for QNX4(Watcom C) not for Neutrino cc.
  • the use of crypt() (search for QNX or qnx in the src files)
  • the use of -lunix.

Maybe an output of the script will be more helpfull ?


au revoir, alain

Aussi haut que l’on soit assis, on n’est toujours assis que sur son cul !!!