problems during install 6.2.1

Hi! As I see, lot of newbies here (as me too) have some problems with instaling the latest build. I also did download the qnxnc6.2.1.iso file, put it on a cd and booted my PC waiting to see something reliable what I couldn’t imagine…
First I also had the problems like

/.diskroot file for root not found on any filesystem
unable to locate fs-pkg

or later

unable to mount a qnx4 filesystem as /fs/hd0-qnx4 on /dev/hd0t79
 (corrupted filesystem detected)
no qnx 6.1 or greater filesystem available to mount

Then I tried to experiment a bit and when i chose F10 (Force a partiton install) almost everything seemed to be fine. But after some steps and also after trying other installation options I still freeze when a command occures on my monitor:

unable to mount /cd//boot/fs/qnxbase.qfs as /qnxbase

Please, could You write me what should I do? For example to let me know what kind of partition should I create with PartitionMagic8.0?
//PS:Is it possible that there is ‘only’ a hardware conflict? I am using a WinME on a P4 computer, MB Gigabyte8IDX3 256 DIMM SDRAM, DVD ROM Artec ATAPI HDD AT-bus WD400BB,Ultra ATA/100
Thank You for a reply, I am sure You can help me. mark.

I have many problems to install QNX 6.2.1. As I think, it is not necessary to create a special type of partition to install QNX 6.2.1.

I have used Partition Magic, creating a non formatted partition.
The QNX cd detects the partition, so you can install QNX in it. You can try
formatting it to FAT in QNX does not detect the partition.
After that, the install of QNX to that partition must be ok. But I think there are some problems with hardware. I have tried to install QNX 6.2.1 in my notebook and I had many problems ( I could not do it). In another desktop computer ( I had no problem at all), with the same program of QNX 6.2.1.

I hope it helps you.

I think you have solely hardware problem, and suspicious hardware is your DVD ROM. Can you use CDROM drive at least during installation? Also, check configuration of IDE devices, you shouldn’t have masterless slave on channel (despite of the fact “this is working in windows”).

Thank You much for Your reply. OK, I can try to change my DVD drive. Now I am not home, I will do it about on 29th of August then I will let You know, if it works:) [hope it will]

I tried to install 6.2.1 yesterday (i installed it 1 year ago and all went fine), i selected “Force Partition Install” cause it didn’t recognize my empty partition (40gb hdd IBM on Primary Master), all went fine but on reboot it says
/.diskroot file for root not found on any filesystem
unable to locate fs-pkg

Why? 1 year ago it was running perfectly and now it has problems? Sorry for my english and help me if u can :slight_smile:


Heyyy!! i am so happy now!! thank You, Mr. ed1k! i only changed my cdrom drive and everything worked on the first attempt. i still can’t believe it… :]
PS>>blueocean: i think, that a change of cd drive for the time of booting and installing qnx would not kill You, and maybe it could even help You, Mr. blueocean

A year ago you were unable to install QNX 6.2.1 :slight_smile: If it’s same hardware, try to check that you don’t have masterless slave devices on IDE channels.

2mrk: I’m glad to hear you’re enjoying QNX :slight_smile:

ed1k: yeah, it works, only i don’t have much time roght now to check out it’s possibilities. i found out that the qnx help documentation is a ‘book’ for long nights. i am just wondering if there is any all-commands-list, because i couldn’t find any. [maybe i am looking on wrong places, or let it put this way: maybe a little bit lazy to look for something what someone knows exactly where it is… ] mrk. … l#NtoUtils

Same list you have locally. Just launch Helpviewer and select QNX Neutrino → Utilities Reference.

Thanks! I am here to let You know i’ve already found it! But i am still unhappy, 'cause i dont’t know how to get the i-net work on my qnx. i tried to “mount /dev/modem1” my internal modem(motorola SM56), or to “mount /dev/ser1” my external Microcom DeskPortePocket, but nothing happened. I find the Helpviewer a little bit difficult, i’d rather try something like a step-by-step guide if one exists. But thanks anyway, i realy appreciate Your work, i still can’t understand how are You able to give replies to all our questions ;] mrk.

If motorola SM56 is winmodem (soft-modem when most DSP functions calculated by CPU) you’re out of luck with this card. Winmodem won’t work with QNX (unless you write a driver). External COM modem should work fine. You don’t need mount anything. You should start Dialer application from Photon shelf or qtalk if you work without Photon. I’d advise you to get some kind of “Unix for newbie” book. Also you might want to read “RTP Sysadmin guide”, it is uncomplete but it does include a lot of useful information. I hope QSS’ tech doc team work hard and some of new releases in the foreseeable future will include complete document (they’re working on it AFAIK). … s/wip.html

Hm… my external started to ‘work’, only connection fails during dialing because a “no dialtone” message comes out. I tried to set the dialing to pulse and later to tone, but none helped.
btw: Thank You for the link to SysAd Guide, I 'll find it usefull. And yes, You are right I will get a Unix for newbie-kind book, because I have no former experience with a Unix-like OS. Now I know maybe it would be better to have a interstage between my Windows and QNX :]