Boot by usb floppy

Just I tried to install QNX 4.25 on a PC wich hasn’t a floppy drive. So I tried it with a usb floppy but the booting process stopped like this:

Pess Esc for alternate OS .C

Can somedody tell me what the “C” is meenig and does thereany other error code exist ?

That won’t work. QNX4 doesn’t support booting from USB floppy.

The CD is bootable though.

Thanks, but do you know what the “C” is meening. Or isn’t there a special error code?

I think it means checksum error

Hey all,

A related question, does QNX 4.25 support USB CD-ROM boot?

My guess, no.

Yes and no, the install CD-ROM boot doesn’t but if you make your own CD-ROM or USB key yes it supports it.

Did anybody successfully boot QNX4 from USB key?

yep, I too am interested in booting QNX 4.25 from a USB thumb drive.

There seem to be a sprinkling of responses related to this, but I have yet to find detailed instructions.

If I get it first, I will post here.



I can boot from my USB flash Kingston 2G in DOS and QNX.
This is my kernel:

$ boot -v

$ Proc32 -p 1024 -l 1

$ Slib32

$ io-usb

$ Fsys -a -r 16384

$ Fsys.umass fsys -n hdu

$ mount -p /dev/hdu0 /dev/hdu0t77 /

$ sinit TERM=qnx

you should have 77 patrition on your flash with QNX.
you should also run

/boot/sys/Slib16 &

in sysinit file. Slib16 started in “.boot” before, but your “.boot” file will be too big with Slib16 and will not work.
I also think it will work on USB floppy if you mount appropriate device, but I didn’t try.