Unable to mount /dev/hd0


I’m trying to install QNX 6.2.1 on a Dell WorkStation 400 MT. It’s an
older machine that was “Designed for Windows 95”. I have two hard drives in
this machine. The drive I would like to install to is the primary master.
It’s a 13 GB hard drive with three primary partitions. The first two
partitions are 3 GB, and the third partition uses the remaining space. Fdisk
from Knoppix reports the following:

Disk /dev/hda: 13.6 GB 13601193984 bytes
255 heads, 63 sectors/track 1653 cylinders
Units = cylinders of 16065* 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 392 3148708+ 7 HPFS/NTFS
/dev/hda2 393 784 3148740 4f QNX 4.x 3rd part
/dev/hda3 785 1653 6980242+ 7 HPFS/NTFS

I would like to install QNX on /dev/hda2. I booted from a floppy, pressed
the space bar for boot options, and then selected F10 (force a partition
install). After I went through the partitioning options, I got this:

Restarting driver and mounting filesystems…
Executing devb-eide blk auto=partition eide nobmstr fullscan
Unable to mount /dev/hd0

Partition installation aborted!
Please remove the install floppy and CD, then reboot your machine.

I have tried “Allow the QNX partition to be anywhere on the disk” and
“Install the QNX partion below 8.4G”. I have also tried both the regular
partition loader and the one for older BIOSs. I also tried setting the boot
flag on /dev/hda2. I always get the same error message. Does anybody have
any suggestions?

Sorry, forgot the sig.

Remove the part about Unsolicited Commercial Email to reply.