Weirdness with QNX4.25/Photon/QNX Windows/qwinph under VPC

We’re facing an issue where our QNX consultant guy needs a new laptop. However, he’s primarily working on applications that run on QNX 4.25 and QNX Windows 4.24. Also, he needs a display resolution of at least 1024x768 for his applications. This is making my job (finding him a laptop) challenging.

I’m currently exploring three options. One is trying to get this all working on a Dell Latitude C600 that I have available. One is trying to get it working under VMWare. The last, which has proven the most fruitful so far, is getting it working under Microsoft Virtual PC (hereinafter referred to as VPC).

Under VPC, I can get QNX installed just fine. The floppy drive works, which allows me to install all of our licensing. I can run QNX Windows using gr.vga, but only at a resolution of 640x480. gr.vesa2 gives me an error about missing Int10 (I’ve heard a few places that 4.25 broke the gr.vesa2 and gr.vga256 drivers, so perhaps that’s what that’s about). None of the other video drivers seem to work with VPC. Networking is up and running just fine.

Since I’m not having any better luck with the other solutions, I decided to try to get Photon up and running and then use qwinph.

Photon comes up fine with the flat drivers. I can then successfully launch QNX Windows using qwinph. (Or by manually running gr.phi or gr.phim and then windows.)

Unfortunately, at this point it goes kind of south. It displays teh QNX Windows screen, the little red pointer comes up, I believe I can move it around a little, but it doesn’t respond to mouse clicks at all. I’m not sure if it’s that it’s not processing mouse clicks or if QNX Windows has crashed at that point.

In case it helps, the messages in the window where I launched qwinph are:

And then that’s it.

Anybody have any idea what’s going on here?

[For the other two options, in VMWare I can’t seem to get the floppy drive working so I can install the licenses for photon and tcp/ip, although it worked during the installer to install the QNX and QNX Windows licenses, and on the actual laptop, I can’t get QNX Windows or Photon up in any resolution other than 640x480 – if I try to use another driver or another mode on an existing driver that’s working, the screen fades to milky white then fades to all black and stays that way.]

Not to sure about the mouse problem, haven’t had any experience with the qwinph. But in regards other drivers on the laptop, we had tried using gr.scitech on some laptops which displayed similar problems to what your having (milky white to black/scan lines)…

The way around it we found was to plug in an external monitor after booting into QNX Windows, switching between Local Monitor/External Montior/Both. Eventually the laptop screen would show correctly and at a resolution of 1024x768! A rather round-about way but works until you shut the machine down n start again.

From memory, this still worked if you had the machine in standby, only seemed to die if you restarted QNX/QNX Windows.

And sorry to hijack the thread, but think it is related.

What experience does everyone else have out there with QNX Windows VGA drivers and the latest desktop cards out there? Always on the lookout for cards that are available AND work with QNX Windows (at decent resolutions obviously!)…

Good luck!

We are using ATI 9250 card, with Pg.radeon and gr.phi.

Thanks for the info. about the monitor workaround. I’d probably be okay with doing that myself, but I doubt our QNX folks here will be satisfied with that, unfortunately. :frowning:

I’ve got the entire shebang going in VMWare now as well as MS Virtual PC. It displays the exact same problem: When I launch qwinph, QNX Windows starts up, everything seems hunky dorey, I get the little red cursor when I mouse over the QNX Windows screen, but if I click, nothing happens. If I move the mouse away, it turns back into the white Photon cursor, then in future when I mouse over the QNX Windows screen again, the cursor doesn’t change. Also, if I open another window overtop of the QNX Windows one and then move it, the image of the new window I’d opened stays there. I take this to mean that it’s not just a mouse issue, but is QNX Windows crashing. :frowning:

I don’t know if I have the most recent version of the qwinph package or not; I’m not sure where I’d go to obtain it if I don’t.

I’m having another problem in VMWare: When I use the VMWare video driver, the performance is nice and snappy. I’d like to use that, obviously. However, my mouse pointer disappears whenever I move the mouse. This happens even if I disable hardware mouse. If I use the flat family of drivers, it doesn’t occur, but performance isn’t very good.

I haven’t tried qwinph on the laptop yet.

Replying to my own post, I know, I know. It seems that the ‘cursor disappearing’ problem only happens if I tell it to use 8-bit colour. Selecting a 32-bit colour resolution solves it. Perhaps a palette issue.

I still have the issue where qwinph seems to lock up right after it finishes launching. So close, yet so far!

Seems a bit strange that they are “QNX Consultants” yet it is you sorting out their PC’s for them, Shouldn’t they be doing that? :smiley:

Anyway yes getting QNX windows working with modern machinery is somewhat of a nightmare. The latest QNX updates contain drivers for all radeon chipsets, and the intel extreme 2 PCI bridged VGA adapter (gr.generic gr.radeon and gr.i800) not sure if that will help you. You will probably have more luck running native than via VMare or MSVPC. You could also try asking QNX support they are very helpful and a years basic support contract doesn’t cost very much at all.

QNX Windows works fine for me on MS VirtualPC with Scitech Drivers.
Try them :slight_smile:

Virtual PC is probably best solution for working in QNX Windows.

yeah it works fine for us too, without the scitech drivers. the normal gr.vga works fine. How do you start your scitech drivers? (just out of interest because I have heard alot about the scitech drivers but never seen how they are used)

Works fine on VmWare for us, with the vmware gfx driver and gr.phi. We always use qwinph.

pls can anyone send me the qwinph to my email? or attach here.
or just tell me where to find it…i can not find in the qnx website.
thank you

Make sure phi.cohort is running. My mouse wasn’t responding either in QnxWindows for photon. Create a symbolic link with this command:

ln -s /qnx4/qwinph/bin/phi.cohort /usr/lib/windows/bin/phi.cohort