PNG problems

I’ve got some PNG icons, which under 6.2.1 tended to work as pictures
on PtButtons. Now I’m on 6.3 I’m having some difficulty using them. When
I import them in PhAb, they look fine in the image preview, but do not
show up at all on the button. The same applies if they are loaded at
runtime and PtSetResource them onto the button. The GIF version of the
icon works OK, but look rubbish due to their lack of alpha blending.

I can use some PNGs, which do not have transparency, but again, they
look bad on PtButtons. Is this a known problem, after all, they tended
to work under 6.2.1 (some of them could crash PhAb if I used them though).

One more thing, anyone got any recommended tools for scaling graphics
under QNX, other than ImageMagick or XV? Nothing against those tools,
but I’m after something smaller, with good quality scaling and image



I believe this is a graphics driver problem. I’m trying to do exactly
the same thing. I created a test project in PhAB some number of
months ago that uses a test PNG image. The image is loaded onto a
couple PtButton widgets. It’s supposed to look like a red button with
an alpha blended edge and transparent around. This worked fine

Now when I load the project up again, it doesn’t work at all. I get
the same problems you’re seeing. Just to make sure it’s not me, I
copied the whole project onto a thumbdrive and brought it to a
different machine. The image worked fine there.

I’m going to open a support ticket with QNX.

Hello aaronf,

Did you open a support ticket and, if so, what was the QNX response?

Sorry for the late respone. Not sure if you’re still looking for a
solution to this, but we believe this to be a driver issue. We have
two machines. The same project works fine on one but not the other.
The one that works is using the i830 driver. The one that doesn’t is
using i810.