Has anyone installed QNX onto a multi-boot machine ?

Has anyone installed QNX 6.2.x or 6.3.x onto a multi-boot machine ? I am thinking about doing a multi boot with WinXP and QNX and/or Linux. Any problems - suggestions - advice ?
Thanks !

I have QNX on a machine together with WinXP. Usually WinXP overwrites the QNX bootloader when you install it after QNX. Just use the dloader command from a QNX boot CD to restore it.

I would venture to guess, that outside of embedded targets, pretty much everyone here has a multi-boot with either windows or linux or both. Even if you rely on VMWare for a lot of work, most people also have a native partition, for doing driver development. I myself have Linux/Windows/QNX partitions.

It’s actualy nice to have VMWare use a physical partition. That way you can use VMWare under Windows/Linux and also be able to boot QNX6 natively.

if you do not like QNX’s bootloader for its request for fast response : I myself use “xfdisk”. it’s freeware, use your favourite search engine. in case you can not find it, come back or email me.
regards HELGE


When I used to be at Clemson University, we used triple boot systems on all our lab machines. Here is the installation guide we followed:-

Hope this link worked (i just checked it).


I’ve been wanting to try QNX for about three years, since it was bundled on the coverdisk of a magazine. But I never found the time and motivation simultaneously.

Now, I’ve the time, and might be moving to a career that requires RTOS exprience, so I downloaded 6.3.0-linux-200405141126.iso.

I hope you’ll excuse my questions, if they appear too naïve. I know my way around Linux, and around Unix in general, but have little experience of dual-boot since I abandoned Windows altogether around six years ago.

openqnx.com/index.php?name=N … le&sid=213 describes installing QNX on a FAT partition, without burning the ISO file to a CD. Am I right in thinking that I could do something similar by mounting the ISO file in Linux using the loop option?

[code]sudo mount ~klrhodes/QNX/6.3.0-linux-200405141126.iso /media/loop/ -t auto -o loop

ls -al /media/loop/
total 415666
dr-xr-xr-x 3 root root 2048 2004-05-14 14:17 .
drwxr-xr-x 16 root root 4096 2006-06-09 05:12 …
-r-xr-xr-x 1 root root 138 2004-05-14 14:17 autorun
-r–r–r-- 1 root root 295 2004-05-14 14:17 BuildVersion.txt
-r-xr-xr-x 1 root root 1834 2004-03-13 05:00 caution.gif
-r–r–r-- 1 root root 9278 2004-05-14 14:17 install_notes_linux.html
-r–r–r-- 1 root root 12 2004-05-14 14:17 media.inf
dr-xr-xr-x 2 root root 2048 2004-05-14 13:47 MEULA
-r–r–r-- 1 root root 174 2004-02-20 15:58 pointing.gif
-r–r–r-- 1 root root 408558452 2004-05-14 14:16 qnx_linux_setup.jar
-r-xr-xr-x 1 root root 16933284 2004-05-14 14:16 qnxSetupLinux.bin
-r–r–r-- 1 root root 127395 2004-05-14 14:17 release_notes.html[/code]

So far, so good, but will I be able to install on what Linux sees as /dev/hdc2 without messing up GRUB on my MBR or my other Linux filesystems?

Filesystem Size Used Avail Use% Mounted on /dev/hdc2 4.8G 524M 4.1G 12% /media/hdc2


You downloaded the QNX Momentics development suite for Linux. With it, you can develop, compile and debug apps for QNX Neutrino under Linux - but you require a second machine that actually runs the QNX operating system.

If you want to install QNX Neutrino itself as on OS on a PC, you need to download the Neutrino CD image.


I must be having a bad week, with my brain out of gear.

I’ve trawled through all the parts of the download section of QNX.com, and I couldn’t find a CD image to install the basic Neutrino kernel and OS.

Several packages mention it, but no explicit “this is it” jumps out to grab my attention. :unamused:

After reading a couple of other threads (a search for “noob” and “newbie” was very useful), I found what I believe to be the things I need:

6.3.0-qnx-200405141702.iso should be the OS and associated tools,
ntocore-6.3.2-20060811628-nto.sh should be the update to the Neutrino kernel
6.3.0sp2-qnx6-20052661645.sh should be service pack 2

Right so far?


You’re on the right track ;-)

Thanks for the encouragement, Mario.

So I burned 6.3.0-qnx6-200405141702.iso to a CD and booted as a “live” system (without installing anything).

It seemed to run OK; detected my SCSI card, set up the Radeon video card, so I decided to install to the third hard disc.

First problem: I have a French-layout keyboard, and I couldn’t find a way to make QNX load the right keymap. Luckily, I could remember where the keys are for the QWERTY layout.

I partitioned this 10GB disc, chose to dedicate half of it to QNX.

I also chose to install the QNX bootloader on this partition, and NOT to overwrite GRUB on the MBR of my first disc.

I got through installing Momentix to the default location, but the next part messed up:

[code]GNU Public License Utility? Y
Installing qnx6-host
Installing qnx6-target
An error occurred during the installation
Do you want to continue? y

Instaling qnx-qde
An error occurred during the installation
Do you want to continue? y

Instaling qnx6-target-gpl
An error occurred during the installation
Do you want to continue? y[/code]

Lots of messages flashed by, far faster than I could read them, let alone take notes.

There were no more prompts, so I thought the rest of the installation had gone smoothly.

I rebooted the machine, and at GRUB’s prompt, I typed:

rootnoverify (hd2,0) chainloader +4 boot

This seemed to work for the first few seconds:

Hit Esc for .altboot ...................................... ................................................................. ................................................................. ................... [I don't know how many dots]...

but then the machine just hung.

I tried setting the BIOS to boot directly from hd2,0 and got:

Boot from CD : Press F1 - F4 to select drive or select partition 1,2? this timed out to 1 Hit Esc for .altboot .....................................S

Any ideas what I did wrong?

I don’t expect to have hardware problems at this point in the boot sequence, since QNX booted live off the CD…


I never seen or heard about the problem you had during the installation. Are you sure the CD is correct, did you checksum the iso file before burning it?

I’m not familliar with GRUB and how or if it could interfer with QNX loader.

I didn’t checksum the ISO before burning it… but I just did, and it is OK:

$ md5sum 6.3.0-qnx6-200405141702.iso 462303b2f69e3e20b7dee3bbc9d7dc66

And from the QNX site:

Filename: 6.3.0-qnx6-200405141702.iso Size: 523.63 MB Classification: Commercial Check Sum: 82346462 549060608 MD5 Sum: 462303b2f69e3e20b7dee3bbc9d7dc66

When I saw the problems with the GNU parts of the disc, I wondered about data corruption, but if the md5sum is correct, this can’t be the cause of the problem.

I’ll try other chainloader offsets.


Right, I got QNX installed and booting.

As I mentioned earlier in this thread, I saw some error messages during the installation process.

When I went back into Linux and used fdisk to check the partition table for /dev/hdc I saw a warning that the partition did not end on a cylinder boundary:

[code]fdisk -l /dev/hdc

Device Boot Start End Blocks Id System
/dev/hdc1 * 1 1170 589648+ 4f QNX4.x 3rd part
Partition 1 does not end on a cylinder boundary

/dev/hdc2 2341 12486 5113584+ 83 Linux[/code]

I saw a comment in another thread about the “cylinder boundary” warning; the user also had a problem booting QNX.

So I deleted all the partitions from the disc, and used fdisk to create a partition for QNX. Then I rebooted from the QNX CD Rom.

QNX didn’t want to use the partition I had created for it in Linux… and to avoid having the partition boundary not fall on a cylinder boundary, I let QNX take the whole of the disc.

Again, I had QNX install its own bootloader to what it calls hd2, but NOT to hd0.

This time, there were no error messages. Great!

I took out the CD Rom and rebooted the machine. At GRUB’s prompt, I typed:

rootnoverify (hd2,0) makeactive chainloader +1 map (hd0) (hd2) map (hd2) (hd0) boot

QNX booted, detected hardware, and I got the login screen. :smiley: :smiley:

I have since booted again, and found that I don’t need to use GRUB’s map command. I might not need the makeactive; I’ve not tried yet.


I’ve tried a couple more times, and whittled GRUB down to:

rootnoverify (hd2,0) chainloader +1 boot


great you’re in !
welcome to the show …