problem connecting USB


I am trying to mount my mass storage USB key (SanDisk) however, I cannot start io-usb. When trying to connect the USB with

io-usb -duhci &

I get the following error:

“/bin/sh: io-sub: not found”

I am using QNX6.2.0 RTP.



Hmm. Something sounds fishy here as you should not get that error unless you have a pathing problem or an incomplete install.

io-usb should be located in the /sbin directory.

First, what does ‘which -l io-usb’ give you? It should come back with /sbin/io-usb.

If it does not, make sure your logged in as ‘root’ to ensure your getting the correct paths set (they may not be for a non-root user). If you are root then do a ‘cd /’ followed by a ‘find . -name “io-usb”’. This should come back with the location of io-usb if it’s on your system.

If it’s still not found then you don’t have a standard install of the 6.2 O/S and so you’ll need to copy io-usb to that machine from a standard install (or re-install 6.2 entirely).


Unfortunately it seems that I do not have “io-usb” anywhere on the drive.

would it be possible to forward me the file? this way I don’t have to re-install (i don’t have any other machines running QNX).

thanks for your help.

I’m running 6.3 SP2. So my io-usb is different than the one you have and most likely incompatible with 6.2.

Maybe someone else can upload io-usb for 6.2.

If not your going to have to put back in the CD and either re-install or search thru all the zipped up archives on the CD for io-usb.


I run QNX 6.2.1 and it doesn´t have io-usb either. The command for my version is devu-ohci or devu-uhci, depending on what controller you have. What you need to do is start the Helpviewer and search for usb: it´s all in the documentation here. Apparently io-usb was introduced with QNX 6.3