ssh and X DISPLAY

when I "ssh -X " I have no DISPLAY Env var so I can launch any
xterm or x based app. I can not ever set the DISPLAY to :10.0
or any 6000 port cause there is not one listening.
I have checked setting in sshd_config and I have the
allow_X_forwarding (or whatever it is) set correctly.
ant clue ?