QNX 4.25 on large Hard disks. BIOS problem.

I put this topic first in the General/Newsgroups/qnx qnx4 Forum , but I think it should be in this one…

I´m trying to create a backup disk for an old system. The smallest hard drive I could get is 80GB.
The hard drive is Hitachi.
The PC setup assumes the hard disk capacity as 125MB.

When installing QNX 4.25, the installer ask if the machine is a “value point machine”. I answered “n” and prompted to accept the Fsys.ide as the driver for the disk. I typed “n” and was prompted to select the driver from a list. I selected Fsys.eide.

The step that fails is mounting the partition and says:
NO BIOS SIGNATURE in partition sector.

I tried to force the geometry of the disk to some smaller size disk configurations ( in the PC setup and with the “install -p” parameter)
install -p " eide -c 16,2114,63"

install -p " eide -c 64,512,63"

install -p " fsys -h64,63 -i eide -c 64,512,63 -l "

With another QNX 4.25 booteable hard drive, I tried to edit the partition table (using fdisk) of this hard drive in a slave role. But I got the same messsage.

Any suggestion?


try Fsys.atapi !!!


Beware, with Fsys.atapi the geometry of HD will differ depending on wether the driver is set up as master or slave.