Corrupt file - /bin/sh

Extreme QNX rookie here so bare with me…

Somehow we managed to screw up/overwrite the SH utility and now we get an error upon booting into QNX 4.25 that basically says /bin/sh is hosed. So, there are two things I have been trying to do:

1 - I have a copy of the original QNX partition that I copied with Norton Ghost before the issue arose. I cannot get it to boot, hangs up at “press ESC for alternate OS…”. I’ve done some reading and from what I understand I will need to run the ‘boot’ utlity to have QNX setup the boot sequence properly. Unfortunately I do not have any of the original install software and no boot disk. Is there an easy way to make a boot disk from a good system to use? I found the instructions on how to create a boot disk on the QNX drive, but can’t seem to get my script to run correctly.

2 - I have 7 other computers running QNX 4.25. I have tried to mount the drive into another computer to see if I can copy SH from a good system to the bad system drive. It tells me the file system is corrupt when I attempt to mount /dev/hd0.1 /home2 . Any ideas how to make this work?

I’ve been reading until my eyes are bloodshot and can’t seem to find the answers…


Just a shot in the dark (I’m a rookie too!)…

Could you try booting from the CD. It should mount the hard drive for you. Could you try and make the changes that way? Hope this helps!

No CD-ROM on these computers (I could install one if needed), but I also do not have a CD to boot from. I have no installation disks at all…

I was finally able to make a boot disk using the instructions from /etc/readme/technotes/qnx_install but I still could not mount the drive, it still gives me the same corrupt file system error as when installing into a running QNX system. The file system should fine though, I am about 99% sure all we messed up was the SH utility.

You need to mount the filesystem home2 to the partition not to the whole HD.

Try mount -p /dev/hd0.1

This should make /dev/hd0.1.t77 come up (or name close to that)

then mount /dev/hd0.1.t77 /home2

Yep, trying to mount the whole HD was my error. I used the following and it worked nicely…

mount -p /dev/hd0 /dev/hd0t77 /home2

Thanks for your help on that!

However we couldn’t wait any longer for me to try and learn enough to fix it and ended up sending out the drive we screwed up to the folks who installed QNX for us originally to have it reinstalled. So I don’t know if I could have replace the SH utility and got the system going again. Oh well, I’m sure we’ll screw some more stuff up and get a chance to go through this again!


If sh was corrected it most likely other stuff got corrupted as well ;-)

Good luck