Dev16/32.ser and Pentium IV modem issue


I noticed a strange “serial port” problem with Pentium IV SBCs and
standard Pentium IV desktops (IBM ThinkCenter) that is probably due to
the PCI/ISA bridge and I am wondering if there is a

Note that this happens ONLY with Pentium IV’s. Everything is perfect
with Pentium III SBCs or desktops.

The modems used were USR Courier V.Everything External and USR
Sportster 56K External.

I made these tests with QNX 4.25 Patch G and the results are exactly
the same with Dev16.ser or Dev32.ser.

The serial port was locked at 57600 or at 38400 Bps and a DB9 to DB25
serial cable was used.

Here’s the problem :

-I sucessfully establish a modem connection with a remote QNX system.
-The connection baud rate vary between 28800 and 33600 Bps.
-When I start a file transfer (qcp or zmodem), the speed is around 300
cps and transfer can hang for seconds. Often, the transfer cannot
finish because there are too many errors so QCP exits and I’m back at
the remote terminal.

In the same computer or with the same SBC, I install an internal PCI
modem (USR Sportster 56K Pro) and the transfer runs perfectly around
3000 cps with a little or no error at all.

I repeated this test using different phone lines and different remote
hosts and I am always getting the same results.

Here are other things I’ve tried with the exact same setup :

-Booted with DOS and transferred a file : works pefectly, great speed,
no error
-Booted with Windows XP, transferred a file : again, perfectly, great
speed, no error

Back with QNX, I tried to lower the lock rate, and I even tried to
connect at very low speed like 9600 Bps, or 2400 Bps and the transfer
rate is proportionally sluggish and there are a lot of errors/the
transfer hangs for seconds or stops.

Anybody experienced this problem ?



Could this be related: