Lan91c111 problem on QNX 4.25


I’m working a x86-based board with two smc91c111 network NICs, using
the Net.ether9000 driver shipped with QNX 4.25. However I’ve problems
getting it work, when I run the driver for the first time, with
command line like this :

Net.ether9000 -p 0x200 -i 5 -v

it can find the card, with the following output:

Net.ether9000 Driver initializing …
ROM not detected
I/O Port Base … 200
IRQ … 5
Detected SMC91C0
Autonegotiate returned 0
MDI_GetActiveMedia returned 3
Mode = 100BTHD
Net Address … 001719 f33292
Using 10baseT connector

Then I run the driver for the second(and third, …) time, it emits a
very confusing message:


and then exit.

The card works find under VxWorks, and also on QNX 6.3 with slight
modification on the driver source.

Can anybody give some hints for troubleshooting? thanks in advance.

Best regards,

You are not running the subsequent drivers with the same i/o address
are you ?

Yes I run it with the same I/O address. I’ve figured out why it
outputs different message on the second pass – should do a `slay
Net.ether9000’ before the second run.

I believe QNX 6.3 driver for the same card needs a small patch
regarding initialization sequence to work after some time comparing
VxWorks source and QNX source, now I wonder if the 4.25 source is
available so that I can apply the same patch, or else I’ll have to do
a binary patch.