Target Board IDE Flash Drive Copy to a New IDE Flash Drive

Hi Experts,

I have an SBC(Single Board Computer) with a set of pheripherals ports
available on it(such as Seial port, VGA port, PS2 port) along with
IDE Flash Drive of 64 MB made from ICP. Target board Boots with this
IDE Flash Drive only.

I took one more new IDE Flash Drive of 64 MB made of ICP. I connected
to Host system running with QNX with a different hard disk.

I used dd command to copy the contents of original source IDE Flash
Drive to New IDE Flash Drive using ‘dd’ command.

I disconnected the IDE Flash Drives from Host., and Connencted the New
IDE Flash Drive to my target board and its booting and working same as
the original IDE Flash Drive. Till this part verything is fine. My
problem is:

I took a new IDE Flash Drive of 128 MB from a different manufacturer(I
mean its not made of ICP) and I tried to apply the same procedure
explained above.

When I try to Boot the target system with this newly copied IDE Flash
Drive (128MB ) The message I get is “Missing Operating

I searched for resolution on this issue in newsgroups. I applied
all they suggested. Still I am getting the same error message.

Steps what I did is as follows: My source drive mount point is

  1. created partition on new disk same as the original using fdisk with
    loader nad boot options.

fdisk /dev/hd1 add -b
fdisk /dev/hd1 loader

  1. run the dinit on the newly created partition.
    dinit -h /dev/hd1t77

  2. mounted the partition
    mount /dev/hd1t77 /hdnew

  3. Copied the entire contents of the source driver to destination
    cp /hdold/.boot /hdnew/.boot
    cp /hdold/.altboot /hdnew/.altboot
    cp -vpRX /hdold /hdnew

*** I used the commands perfectly as mentioned in the groups for doing

Still I am getting the same error message.
can anybody give your valuable any suggestions/help on this issue?
Your advices are always appreciable. Thnaks in advance.

With Reagrds,

Hi Jai Kumar,
Thnak You for your reply.
First I tried using DD command only, But in newgroups they suggested
for not using dd and ghost.
Even when I used I got the same error message.


have you tried using DD if=/dev/hd0 of=/dev/hd1 :question: