Problem during login (can't login at all!!!)

Hi guys,

I am running QNX 6.3 on a single computer board (Ampro RB800) with an Intel 686 processor. I used to login as a root with no password. The system was running properly until it crashed when I started Momentics for apparently no reasons. After rebooting, the system did not allow me to login as a root saying that the login is incorrect. I’ve tried to use different usernames but it is the same problem! It seems that the logins might have been damaged or erased somehow!

Then I connected an optical drive to this machine, ran the OS from the CD, mount the hard drive. Then I ran chkfsys on my drive to clean it up from the possible filesystem errors. This went ok. But I still can’t login with any of the user logins…

Is there anybody who knows how to examine and repair the password files? And what to do next?

Thanks a lot for your help,


Sorry guys, I found the solution of my problem. I’ve copied /etc/oshadow to /etc/shadow and /etc/opasswd to /etc/passwd and it now seems to work!

Cheers anyway!!!