Building image to a Compact Flash card using USB-CF adapter

I need to build and load a QNX OS image to a 2GB compact flash (SimpelTech or SandDisk ) that will be used as the hard-drive to our PC104 system. I tried first with the in “/usr/qnx630/target/qnx6/x86/boot/build/”

The hardware of the system:
Mother board: EBX-Littleboard 800
PC104 Profibus card.

I am using a SanDisk USB2.0 CompactFlash card Reader/Writer to access the Compact Flash. Here are what I did:
1, io-usb -dehci
2, devb-umass cam pnp&
3, fdisk /dev/hd1, I then fdisk the CF as QNX, 77, and I can see it as /dev/hd1t77
4, cd /usr/qnx630/target/qnx6/x86/boot/build/
5, dinit -h -f bios.ifs /dev/hd1t77
after this dinit command, the terminal displays:" Using loader /usr/qnx630/target/qnx6/x86/boot/sys/ipl-diskpc2-flop"

The .boot file is created in the compact flash. I then plug in the compact flash to the CF slot in the PC104 system, but system stops after “Pressing ESC for .altboot…”

I believe that the loader should be ipl-diskpc2 instead of diskpc2-flop, as I tried the same procedure a while ago which worked fine and I remeber the loader was ipl-diskpc2 at that time. But I don’t know why I have diskpc2-flop this time. The only difference is the USB compact flash adapter.

Could anybody give me some instructions on where I might be wrong? Any other information you may need for diagnosis?

Thanks a lot,

The compact flash is NOT a floppy. The loader you used if for flopopy (ipl-diskpc2-flop)

I use the following commands to initialize my cf-disks:


if test -r $CF_HD; then
slay devb-umass
devb-umass &
waitfor $CF_HD 10

Clear partition table

dd if=/dev/zero of=$CF_HD count=1

Create partitions and install QNX loader

fdisk $CF_HD delete -a
fdisk $CF_HD add -s1 -t79 -p100
fdisk $CF_HD boot -t79
fdisk $CF_HD loader
mount -e $CF_HD
waitfor ${CF_HD}t79 10
dinit -qh ${CF_HD}t79

For Harddisks > 8GB + new Bios

#dloader $CF_HD /boot/sys/ipl-diskpc1
#dloader ${CF_HD}t79 /boot/sys/ipl-diskpc2

For Harddisks < 8GB + old Bios

dloader $CF_HD /boot/sys/ipl-diskpc1-flop
dloader ${CF_HD}t79 /boot/sys/ipl-diskpc2-flop

mount ${CF_HD}t79 /fs/cf
cp -v /cf_qnx/boot/cf.ifs /fs/cf/.boot

umount /fs/cf
slay devb-umass

Depending on the BIOS I use different dloader commands.
Booting from an old 486 was only possible with the last commands.

noc please destroy that bot