press ESC for alternate me

Hello Experts.

I’m new one and have no experience about QNX. Please give me your advice…One of my automatic equiment has QNX based on-board system. one of them stopped yesterday because of disk failure(power failure) and soon I found it won’t boot up at all. So I tried to duplicate image before replacing disk using the one of next equipment. I tried Undisker and WinImage (Windows XP base tool) in order to duplicate disk image. After than I sat it up, I could see the horrible messsage “Press ESC for altarnate OS…” with lot of DOT. ESC key was pressed all night long and all my eyes are still filled with the message and DOT. Next one was good. It showed big QNX logo upon black screen… it seems quite old one… anyway I rebooted it for comparing. I tried it using disk editor and confirmed all contents of disk blocks are identical but situation was not different…same message and lot of DOT…

Q1. How can I duplicate image in this situation…
Q2. How can I clear the message and work it out…
Q3. What is the best way to work this situation out…

please, help me



Your message is a little hard to interpret, but I am guessing that the following are true.

  1. You have some kind of embedded system using QNX.
  2. You are using QNX 2.+.
  3. Your image copy worked. This is shown by the fact that you get the “Press ESC…” message.

In the first case, you got the “Press ESC…” message but the disk did not boot. This could be because, despite the fact that you did a perfect image copy, the boot parameters on the new disk were not identical to those on the old disk. This makes a difference. Without a development system, it will be fairly difficult to reload the OS on such a disk.

In the second case, you did boot the OS because you see the big QNX screen. If this is not the screen you were expecting, it may have to do with the /user/config/sysinit.# file. Here I’m guessing that you have a few machines, each with network cards and different node numbers.
If the node number ##, does not match a sysinit.## file, then the default sysinit file will be used, which will show the big QNX screen. To fix this, you need to login with a user-id and password, and copy the sysinit file. How would you do that? After logging in, run this command:

$ tsk info

You should see the node number of the machine. Then:

$ cd /user/config
$ ls

Let’s say that you are node 3 and you see the file sysinit.4. You could then copy with:

$ cp sysinit.4 sysinit.3

Then you could reboot and try again.

Of course, you could be using QNX 4 in which case things would be different.

Thank you for your reply. In my case is what you said first.
Yesterday,I recovered the contents of the old disk by using QNX6 disk. In this process I found that there is a flash memory on the board and this old disk is for use if there is some problem with boot during reading flash’s.
Also, I recovered the flash util and .out file on the old recoved disk.

In my guess, If I can down-load that .out file by using flash util which I found at the old disk the boot will …seems to be done because the old disk is for recovery purpose. In normal boot process, the old disk is not used.

My english is not good so I will briefly explain my situation with simple sentences

–Situation –

  1. I have some Equipment, the OS is QNX4.2.4 and it’s not bootable.
  2. Vendor can not support with it because it’s too old one
  3. OS is running on AIS-640 embeded board. bios not support CD boot.
  4. There is a flash memory on the board and it is used during boot up
  5. I have recovery disk which is not bootable but I can see the contents
    by using another QNX 6 installed computer.
  6. recovery disk has flash utils and files to reload contents to flash memory
  7. I can install QNX6 at the Equipment beside QNX4

– Help me –
7. I don’t know how to mount the flash memory on QNX6 after boot.
8. I don’t know the interface type of flash memory but i’m sure that there is a flash memory on the board
9. I don know it’s possible or not

please advice once more…



Since this is a QNX 4 system, you will probably need to boot QNX 4 to run the flash utils.
QNX 4 can boot from a floppy disk. Does this system have a floppy drive? Do you have a
QNX 4 boot floppy?

You didn’t say much about what the Flash is. Some flash is just a soldered in chip. Some is
a removable module, such as a Compact Flash. I mention this because it is possible that the
flash is dead, and that re-load it won’t work. This is just a guess, but a QNX 4.24 system is probably 12-15 years old, and flash memory can wear out, usually do to writes. I’ve never heard of it wearing out from just reading it, but I could be wrong.

Thank you for your advice.
Here goes more detail. plese give me some more…

→ About Flash ←
I’ve checked about the CPU Board and also found the flash chip.
It’s directly solder mounted on board and Mfg is AMD.TSOP type IC… might be 16MB or 2MB
Yesterday night, I tried to take it off from the board and read the contents of device by using
special flash reading device and I got a binary file but It took too long time and even dangerous way to the board because the board is totally obsoluted and to do this is can be cause of malfunction of the other mounted devices…anyway, I need some way not to do this again…

->About flash util ←
I’ve been checking the structure of what i copied, the recovery disk which not work.
I found a program to reload a file to flash memory. I immediatly compared what I read from the device
with this. It’s exactly identical! and I opened the program by using hex editor. It was created the manufacturor with WATTCOM C. Soon I copied it to my QNX6 system with argument whether it working or not. consequently it seems not working in QNX6 because it shows some unknown message.

→ QNX4 ←
I’ve got the QNX CD today from someone. So i’m going to install and execute the flash util.
I’m not sure is it work or not…

In this point, I have some questions…advice me

  1. The flash is mounted on the board. what is the wat to access it…there must be a way to mount…
  2. The developed application in QNX4, also can run on QNX6?

→ floopy<-
The system Board dose not have floopy disk but I found the connector
I’m pretty sure that I can mount floopy device.

QNX 4 and QNX 6 are not very compatible. Their file systems are the same, which can be handy, but otherwise they are not.

I’m pretty sure you can boot off of the CD and and run from it.
You will have to mount any disk devices by hand.

You will need to run the driver. That’s right, the driver is a program.
It will have a name like Fsys.driver. Once it mounts, an entry will appear
in /dev. Something like /dev/hd#. The driver will usually have a parm to control the “hd” part of this name. Once it is mounted, the next step depends on whether the device is partitioned. If so, you wil run the command:

mount -p /dev/hd#

to mount the partitions. They will then appear as /dev/hd#t77.
Finally you need to mount a file system on the device, for example:

mount /dev/hd#t77 /mnt.

You should be able to read it at this point in time. Since this is a flash device, you may need a special utility to write to it.

No, NO, and NOOOO!

Fsys.floppy is the floppy driver. After starting you would mount as:

mount /dev/fd0 /fd

or something similar.

Good luck