PC104 using CF, takes forever to install qnx, how come?

Hi all

Just wondering how long does it take to install a host on a pc104 with storage media using CF?, mine too more that an hour and still not completed ? how come? any suggestion?

by the way the cpu is about 650Mhz



Writing to CF is not a very fast process. I don’t know the exact numbers but I’d say it’s on the order of at least 10 times slower than a harddrive, if not slower. Especially since some CF media is much slower than other types (for example SanDisk Ultra II is much faster than SanDisk Ultra which is faster than plain SanDisk).

2 questions would help determine why it might be so slow:

  1. How big is your CF media and what type is it (normal, Ultra, Ultra II etc)

  2. How big of an installation are you trying to do? A full 6.3 install including Photon/libraries etc is going to take a long long time vs a custom install of a target system that contains only a bare O/S plus your apps.

I also wonder if you might have run out of CF space.


HI Tim

Thanks for the reply

I am using a kingston 133X CF 2GB
and a full installation of all the targets and photo and etc… basic i say yes to all the option

I kinda new to qnx, i heard that i can create a small image of the program i run on the CF, any idea how the thing is dont and where should i read up on that

Please advice


Soon Lee,

First off, I am not sure that 2 Gig is enough space to put a full install including the development environment. I guess by now it either finished (in which case it worked) or it is hung up because it’s out of disk space.

Is there a reason your putting the full development environment on the CF?

Normally when I’ve used a PC104 board I attach a harddrive and put the entire OS + photon + development environment on that. Then I add the CF disk and mount it as a 2nd drive and put a minimal install on the CF (basically the O/S and my apps).

You want to do this for 2 reasons:

  1. Limited space on the CF and it’s quite slow
  2. The CF has a very finite number of write’s that can be done to it before it will become unusable. If you do real development on it (file editing, compiling etc) your going to hit that limit.

As to how to accomplish the small image, there is plenty of info on it and it’s reasonably easy to do (at least I think so). Look in the helpviewer at the chapter entitled ‘Building OS and Flash Images’ (if your using the Momentics suite) or ‘Making an OS image’ if your not using momentics.

Plus ask questions if you get stuck or search this forum because I’m sure this has been covered here before.


Hi Tim Thanks for the advice, you are right i think it hung up, but no message given to say that it is out of space… :frowning:

may i know how to opt for the minimal install configuration?

Soon Lee,

When you say minimal configuration do you mean on the initial install from the CD or on your target system?

If you mean from the CD, then the easy answer is to say ‘no’ to every question when it asks you to install. Of course that won’t give you very much to work with (ie no compilation support). I still highly recommend attaching a hard drive and installing the O/S on that for development purposes.

If you mean on your target system, then most of the answers you want are in the chapter on ‘Building OS and Flash Images’ where if I remember correctly they show a bare bones install (just the base O/S and all the commands, some of which you can strip out if you want to further reduce the image size). You can easily get an image under 1 Meg in size for a very very minimal system (no TCP/IP support, no photon etc).



just got the CF installed using the min config, but yet another problem surfaced.

Error Msg:

“No valid commercial license found”
“Only non-commercial use of this software is permitted”.
“Contact QNX Software Systems to acquire a development license”

“Spawn of /bin/sh failed - no such file or directory”.

It seem that i only have this problem when i install it on a CF, i got one compy one HD never experience this when i first boot up the system, I try out some of the fix found in the forum but does seems to work

any advice?


Soon Lee,

It’s the spawn of /bin/sh failing that’s the issue here (the licence thing is secondary).

I am not sure why /bin/sh would not be there. Is this min config you have the result of saying ‘n’ to all the install questions when installing from CD? Or is this a custom image you built yourself?


it is a install from the CD, with all the options as no,I find it very odd, in the sense that after i activate the product, the same message still appear? how can it be so? odd

Ok guys, just in case some one face the same problem as me, there the fix

For my case i disable the dma on startup(using alterboot),then the problem is solved. The OS can boot normally after than.

Hi Guys,

         I have been having the same problem...the spawn msg. I will try to disable the DMA, and my hypothesis is that it will work, Cause I have tried the same process with many Flash cards, and this msg only appears on the cards which don't seem to support the DMA control. Thus disabling it, would probably work. 


For those having this same problem, It seems that some card don’t support DMA Control. Thus the first time the installation is done you need to press the D to disable the DMA, once in the QNX you must Disable the DMA. I had a previous .build which did not enable DMA, and by using this build. (cp ./Basic.build .boot) It does not give me the

“Spawn of /bin/sh failed - no such file or directory” error mesage.