Looking for a couple 6.0 and 6.1 binaries


I’m looking for binaries for devi-hrun from 6.0, and devu-ohci and devu-kbd from 6.1. Can anyone point me to a location for these? A search of this site and the main QNX site didn’t turn anything up.


Both QNX 6.0 and 6.1 ISO can be found in the Download section of this site. You will probably have to download and install, to extract the files you want.

Just out of curiousity, what do you want with components of this old Neutrino version?

noc: I looked in the downloads section, and may end up doing just that, but wanted to avoid the hassle of installing the whole thing just for 3 binaries.

Thunderblade: I’ve got a 3Com Audrey that I’m trying to get USB support on. I found a Flash image for it with USB support for keyboards and mice, but the USB ethernet dongle doesn’t work. So, I’d like to try to add these libraries to the 6.1 image I have where USB ethernet still works.


Forgive me if I’m wrong, but I think the 3Com Audrey uses QNX 4. There was exactly one model of USB Ethernet connector that it had support for.

Yep it’s QNX4 all right. Unless somebody made a QNX6 image.

exactly. A few people made 6.0 images and one guy made a couple of 6.1 images.

Now this gets interesting. I recall a few years ago I asked one of the developers about a keyboard sequence that I heard would bring up a shell on the Audrey. I was told it existed, but he couldn’t tell me. That’s rather close lipped. Now you are saying that someone ported the Audrey code to 6, and made it available?

yep…The images are described here:


and the download page for them (and many more) is here:

http://www.audreyhacking.com/files/images/?M=D, wirth the ones dating 2002+ being 6.0/6.1



Ok, this is all pretty exciting. I downloaded the images, and took a look at the directions for getting started.
Most of this was about modifying the boot image, which I assume isn’t needed on these pre-modified versions.
I tried using DD to copy the USB file to a CF. I then put the CF in Audrey and powered it up with the right
buttons pushed. The produced the error message:

Fatal: Invalid Image XLv01.12

I guess I’m not doing this right, but I haven’t found any other useful info.


you need the stuff in the attached zip file. There are directions in it, too. (this is all for Windows users, though)



Thanks a bunch.  I think.  This is becoming a very interesting but strange adventure.  After a couple attempts (WinXP/2000 only) and that sort of mistake I got this going.  I didn't realize that my Audrey would immediately be re-flashed, but that's fine.  So long QNX 4 Audrey. 

I loaded the infinity 1.1a image. The results are interesting. Let’s see.
Getting Date/Time from the Internet never seems to work, although it also failed for QNX 4 Audrey. Keyboard worked in a flaky manner at first, but after power cycle works fine. Plugging in a USB keyboard didn’t work, but then probably I’d need to start a driver? No Virtual Photon Screens, boo hoo! Doesn’t seem to be a Voyager loaded. Downloaded a 6.3 “sin” just out of curiosity. Running crashed Audrey. Even so, this is really cool. I guess I will need a 6.0 or 6.1 development system to build anything.

the image I like is the jukebox one. It has Voyager, etc. There are 2 versions. The regular one (jukebox-audrey.zip) and the one with ext USB support for USB keyboards, etc (jukebox-usb1.zip). The latter is the one I like, as my CueCat works with it, but I’ve never been able to get an internet connection. As far as getting the time/date from the internet, I know of a few places set up for Audreys if you can’t get it to work. I had no problems, though.


I’ll try the jukebox-usb version next. I would like to know about a place to get the time if you know of one. I didn’t see anywhere to set this so far.

there are a few ways to do that. You can search for and use an internet-based NTP server, or you can use one on your own network. Like *nix, Windows NT, 2K, XP, Server2003 can all act as NTP servers:


Or, you can add an NTP server to a Win32 machine.


My Audrey, when it has an internet connectiion at boot, has no problems setting date and time.



I was just refering to the Audrey boot-time-auto-time-getter-thingy.  I thought maybe the service it used had moved.  I'll look into it further.



Sorry, I must have misunderstood your message.

I just did a search of the user group for MrHouse (some users use Audreys as thin clients), but couldn’t find an alternate NTP server. I did see that some have commented out the NTP lines so the Audrey won’t try to set the date and time at boot:

Edit the /config/startup-main and the /config/startup-warm files at these lines -

#APP,NOWAIT,FOREVER,settime ← (this is for the Network time, NTP)
#APP,NOWAIT,FOREVER,Time ← (this if for the manual setting)

Do you have internet connectivity? If so, then the jukebox image should be able to get the time. Not the USB one, as the internet stuff doesn’t work “out of the box.”


I do have internet connectivity. I’ll try the jukebox image to see if that has any better luck. The original Audrey QNX 4 flash was having this same problem. It had worked the last time I tried, which over a year ago. That’s why I thought the service it was going after might have changed.