iconv problems

I’m using QNX 6.3 over an intel pc
I have problems when trying to compile gnu glib-2-12-4

when I execute
./configure it throws an error when it checks the libiconv library

here’s the output

/usr/local/glib-2.12.4 # ./configure
checking for a BSD-compatible install… /opt/X11R6/bin/install -c
checking whether build environment is sane… yes
checking for gawk… gawk
checking whether make sets $(MAKE)… yes
checking whether to enable maintainer-specific portions of Makefiles… no
checking build system type… i386-pc-nto-qnx6.3.0
checking host system type… i386-pc-nto-qnx6.3.0
checking for the BeOS… no
checking for Win32… no
checking whether to enable garbage collector friendliness… no
checking whether to disable memory pools… no
checking for gcc… gcc
checking for C compiler default output file name… a.out
checking whether the C compiler works… yes
checking whether we are cross compiling… no
checking for suffix of executables…
checking for suffix of object files… o
checking whether we are using the GNU C compiler… yes
checking whether gcc accepts -g… yes
checking for gcc option to accept ANSI C… none needed
checking for style of include used by make… GNU
checking dependency style of gcc… gcc
checking for c++… no
checking for g++… g++
checking whether we are using the GNU C++ compiler… yes
checking whether g++ accepts -g… yes
checking dependency style of g++… gcc
checking for gcc option to accept ANSI C… none needed
checking for a BSD-compatible install… /opt/X11R6/bin/install -c
checking for special C compiler options needed for large files… no
checking for _FILE_OFFSET_BITS value needed for large files… 64
checking for _LARGE_FILES value needed for large files… no
checking for pkg-config… /usr/local/bin/pkg-config
checking for gawk… (cached) gawk
checking for perl5… no
checking for perl… perl
checking for indent… indent
checking for perl… /opt/bin/perl
checking for[color=red] iconv_open… no
checking for libiconv_open in -liconv… no
checking for iconv_open in -liconv… no
configure: error: *** No iconv() implementation found in C library or libiconv

I have installed the libiconv packge 1.7 that comes on the 6.2.1 repostories

but I tried whith a newer package (libiconv-1.9.2.tar from gnu site )
and it threw the same error

f anybody have an idea, plz reply
Thanks in advance

You probably have to tell glib where iconv is located. This is a configure parameter.

I have the same problem, I tried everything to pass the iconv location to the configuration but no luck. Has anyone able to compile the glib ?

It’s been a while, but I’m quite sure I’ve been able to. Have you tried pkgsrc?

yes I have. the ./configure is not able to find my iconv.h and/or libiconv.so and libintl.h and complain about gettext. But I have them all. I put all of these files everywhere in my QNX so that it can find it from any where, but still no luck. I think ./configure is just not setting the include and lib search path at all.

./configure usually has an option to point at where libiconv.so is located. You can always find its options via ./configure --help.

I have done that and tried the option --with-libiconv=/usr/local/lib/libiconv.so and --with-libiconv=/usr/local/lib both could not find and link the iconv lib.

We’ve got a configured and build libiconv as part of the /opt/crank Open Source ports that we provide and
maintain for QNX users:

It contains a modern (and working) libiconv that you might want to take for a spin as well as a number of
other usefull bits.

Hope this helps,

iconv is also in pkgsrc here (6.4):

ftp://ftp.netbsd.org/pub/pkgsrc/package … 081005/All

See this page.

community.qnx.com/sf/wiki/do/vie … ryPackages


Seanb what is the file name, I can’t seem to find it. Do you also have glib? I can seem to find that either.
Also for libxml++, it’s only 1.0.5 version, but I need to work with 2.0 and up version, but libxml++ has dependencies with libxml2 (which I ported without too much trouble), but I can’t port glibmm because it has dependencies on libsigc (which I have ported), but glib is having trouble. when I try to port glib during ./configure stage, it complain that it ** no iconv() implementation found in C library or libiconv, but I have libiconv.so file in /usr/local/lib/ I think if only I can port glib I can port glibmm and eventually libxml++

Any suggestion, I will try the iconv provided from crank soft but I would really like to get all these libraries work with 6.3.2. Right now I am trying on both 6.4 and 6.3.2 but still the same result.