Howto run vnc server in QNX?

I want to connect vnc server on QNX from XP. I installed both
Xvnc-3.3.7-qnx6-bin.tar.gz and xf86-4301-qnx6-bin.tar.gz
by following procedures:
cd /
gzip xxx.tar.gz
tar -xf xxx.tar

after a reboot…
when I execute Xvnc, it shows errors as below:

_XSERVTransSocketINETCreateListener: …SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn’t already run

Can anyone kindly me how to run vnc server on QNX?

P.S. I had start “inetd &” inside the /etc/rc.d/rc.local.
I can also connect from QNX to XP by “vncviewer”

I thought you had to execute the wrapper script “vncserver” rather than the Xvnc directly.

I try to run vncserver on QNX 6.3.0 SP2 with following errors:
/bin/sh: vncserver: No such file or directory
I even try to run from where it locates /usr/X11R6/bin, still same error.

I guess I did not install perl, but after installed perl from 3th party CD, it still has same error message

does “which vncserver” find it in the right path?
try /usr/X11R6/bin/vncserver

“vncserver” is a perl script that expect /usr/bin/perl. Do you have your /usr/bin/perl ?

execute “which vncserver” returns /usr/X11R6/bin/vncserver
execute “which perl” returns /opt/bin/perl
therfore I create a link as below:
ln -s /opt/bin/perl /usr/bin/perl

then execute “vncserver” returns an error:
: socket failed: Address family not supported by protocol family

What version of QNX 6? Post “uname -a”

It seems you are running on an old QNX 6 where Unix domain socket is not supported.

It shows,
QNX 6.3.0 2004/04/29-21:23:19UTC x86pc x86

Where is wrong?

I finally got a chance to try it on my qnx 6.3.

  1. installed perl from QopenCD project.
  2. installed xf86-4301-qnx6-bin.tar.gz and Xvnc-3.3.7-qnx6-bin.tar.gz from the openqnx project.

export PATH=/usr/X11R6/bin:$PATH


it works fine, no errors.

A few things I can suggest:

  1. Do you have a local X window running the machine? If so, try to stop it and then run vncserver.
  2. Do you have multiple installations of X? check if you have both /opt/X11R6 and /usr/X11R6 directory. You may have to remove the /opt/X11R6

Good luck.

Hi noc,
I follow your instruction but perl from QopenCD is difficult to get.
Can you help ?



You can install perl from other places (eg: 3rd party CD), but you need to make sure that the first line of the “vncserver” command point to the right location of the perl.

One thing you have to remember is Xvnc was compiled in QNX 6.2.X. If you run it on other versions of QNX, it may or may not work. Supposedly higher versions of QNX (eg: 6.3) is backward compatible with old ones. If you encounter any problems, you should report to so that they know they broke the backward compatibility.


I trial the Perl5.5 from QNX Community, I can start vncserver, but first it required, then after modifying LD_LIBRARY_PATH, it is OK and require another thing
----Unknown symbol: fchdir Could not resolve all symbols---------

You’re right I’m using QNX6.3 SP3 now.
I will try to downgrade to 6.2.X

If you still have a link to your package Perl5.8.6_qcc2.95.3_nto6.3_x86
in QOpenCD project. It would be nice.

Thanks noc

First you need to find out whether the
----Unknown symbol: fchdir Could not resolve all symbols---------
error comes with perl (vncserver perl script) or the Xvnc itself.

I am not sure where you downloaded your perl, but if it is a perl issue, you should report the problem to them. You can also try to use the perl from the old QNX 6.2.1: … sitory.qrm