QNX Windows on QNX4 under VMWare environment...

Hello !

I am trying to get the QNX4 RTOS running in VMWare. I had no problem installing the OS and running it. Also the Photon microGUI works with Pg.flatdc driver. But I need to get working the QNX Windows, which uses different drivers than Photon. I tried gr.vesa2, gr.vga and gr.vga256. gr.vesa2 report something about wrong FD structure (?), gr.vga works in 640x480 and gr.vga256 doesn’t work. I need QNX Windows under VMWare in 1158864 or 12801024 resolution.

Any clues how to solve this problem ?

P.S.: I heard that QNX Windows can be started under Photon and are using Photon drivers than…

Qwindows can be embedded in Photon with qwinph. It uses the graphic driver gr.phi or gr.phim. In this case Qwindows runs as
an application of Photon. It also works with phditto (from another QNX node) or phindows (from a Windows os).
Qwinph and the graphic drivers can be downloaded from beta.qwinph.
It was a surprise for me, that QNX4 can run in VMWare. Can you give me more detailed information about it:?:

Yes, QNX4 can be run in VMWare, it has no need to some special configuration. Photon runs immediately, all apps are running, you can emulate all hardware such as floppy, CD, HD, network…
I cannot find QWinPh or any components of it. I also have trouble with trying to update my QNX 4.23 to a 4.25 version which could have gr.photon included. It cannot decompress .tarx archives that are needed by update.

Well, you could try QNX in VMWare, it’s easy and working… I am doing such thing because of running some system with custom application which is running on a radar for educational purposes. If I succeed, there will be no need to get real thing and before doing something on real thing just try it on any window box with VMWare and QNX4 installed.

Something in QNX 4.25 breaks gr.vesa2 and gr.vga256. You can use gr.vga or downgrade QNX 4.25 to 4.24. I think the latest version of QNX Window may have fixed it. If not, just use QNX 4.24 if you have to use QNX Windows with high resolution.

Devon, belive me! gr.phi is the best solution.
I downloaded vmware a few days ago and managed to set up a virtual machine running:
- QNX4 operating system (version 4.25D)
- Photon GUI (version 1.14) in 1024x768
- Qwindows (version 4.24) in 1024x768 with gr.phi
The installation steps are:
- Install Photon
- Run crttrap trap
- Set up display resolution
- Install Qwindows and qwinph
- Run gr.phi (it is a part of qwinph package)
- Start Qwindows (it will not start gr.vga, because gr.phi is still
running). The display resolution will be the same you set under
Qwindows runs perfectly both in full screen and in a separate window.
Thank you once more for the idea, now I can run my older Qwindows applications on not QNX4-compatible notebooks embedded in Windows.

I couldn’t get the floppy to work, everytime vmware would report a fault and stop the VM?

Note that it also works with QNX6 but not in Photon ( VM crashes when trying to run graphic driver). Nice work around is to use Phindows to access to QNX6 machine.

Hello, all!

May I implement native FLEET network (ethernet) between pure QNX4 machine and virtual QNX4 node running under VMWare or Virtual PC control?

P.S. Sorry, English is not my native language.

I have done that without a problem. The MAC address of the QNX4 in VMWare may change every time you restart the virtual machine. You will need to “manage” your netmap accordingly. Or maybe mario’s automap will be able to handle it automatically ;)

Odd, cause in my case the MAC address never changes.

Things that I can think of may contribute to my MAC address change:

  1. I move my host machine (laptop) from office network to home network (using different subnet IP).
  2. I ran multiple OSes under VMWare. Sometimes even with two guest OSes at the same time.

I check it under VMWare and Virtual PC, and it works properly in both cases! Thank you.

Virtual PC works for you? It tried it and it crashed when QNX6 is booting, what version are you using?

Host machine: Win2000SP4 + Virtual PC2004
Guest OS - QNX4.25 Patch G

Ah ok , what happens if you start vedit or wd. For me they sigseg. I’m guessing Virtual PC has problem with 16 bit (vedit and wd use 16 bits code)

Vedit 5.05 and wd 10.6 both works properly.

Wow interesting. Can you send me the output of sin ver. When a ran some benchmark Virtual PC was much faster then VMWare!!! So if I can figure out why it didn’t work…

and what’s the build of Virtual PC? You install from what?

Microsoft Virtual PC 2004 Trial Edition (Build 582)

microsoft.com/downloads/deta … laylang=en

sin ver:
/boot/sys/Proc32 Proc 4.25O Aug 19 2002
/boot/sys/Proc32 Slib16 4.23G Oct 04 1996
/boot/sys/Slib32 Slib32 4.24B Aug 12 1997
/bin/Fsys Fsys32 4.24Y Apr 23 2002
/bin/Fsys Floppy 4.24B Aug 19 1997
/bin/Fsys.eide eide 4.25G Apr 15 2002
//1/bin/Dev32 Dev32 4.23G Oct 04 1996
//1/bin/Dev16 Dev16 4.23G Oct 04 1996
//1/bin/Dev32.ansi Dev32.ansi 4.23H Nov 21 1996
//1/bin/Dev32.ser Dev.ser 4.25A Feb 14 2003
//1/bin/Dev32.par Dev32.par 4.25A Jan 08 2001
//1/bin/Dev32.pty Dev32.pty 4.23G Oct 04 1996
//1/bin/Mqueue mqueue 4.24A Aug 30 1999
//1/bin/Net Net 4.25E Apr 24 2002
//1/bin/Net.tulip Net.tulip 4.25Q Aug 30 1999
//1/bin/cron cron 4.23B Oct 30 1997
//1/bin/Pipe Pipe 4.23A Feb 26 1996
//1/usr/bin/lpsrvr lpsrvr 4.24A Jun 26 1997
//1/bin/Mouse Mouse 4.24A Aug 22 1997
//1/bin/Fatfsys Fatfsys 4.26D Aug 28 2002

Thanks for the info. It appears the version I have is not as uptodate as the Trial Edition. I got it working with the trial ;-(

iozone is 1.5 faster then VMWare. I’ll try compiling a big project, it’s the only scenario where I care about speed in a development environment

pls can anyone send me the qwinph to my email? or attach here. biturbogarret@hotmail.com
or just tell me where to find it…i can not find in the qnx website.
thank you