Installing XFree86 V4.2 on QNX 4

I just tried to install XFree86 V4.2 from the OpenQNX binary xf-4.2-bin-gnx4.tar.gz.
When I run the command XFree86 -configure I got some error messages like:
_XSERVTransSocketOpen: socket() failed for local
_XSERVTransSocketOpenCOTSServer: Unable to open socket for local
_XSERVTransOpen: transport open failed for local/node1:0
_XSERVTransMakeAllCOTSServerListeners: failed to open listener for local

Fatal server error:
Failed to establish all listening sockets

On the OpenQNX page Alex Shepherd reported the same problem some time ago, and as a solution it was recommended byKirk Rusell :

"I would guess that you need to upgrade from Socket to Tcpip, because
Socket doesn’t support unix domain sockets. "

How can I upgrade from socket to Tcpip, I think tcp/ip is running on my system ,because the command netstat -a shows my some ports like ftp or telnet with the protocol tcp.

Can someone help me to get XFree86 running on the system.

Thank you in advanvce.


Looks like you are still using the old tcpip version 4.2x, you can download the free tcpip5 upgrade at … index.html

BTW, in tcpip 4.2x, the daemon is called “Socket” or “Socklet”, and in tcpip 5, they renamed it to “Tcpip”.

Hi, Admin
thanks for the hint. Yes, you are right I’m still using tcpip 4.25. So I will download version 5.