SATA, Fsys.atapi on QNX 4.25

Am trying to follow the “workaround to get QNX4.25 running on SATA disk”…
EIDE disk with 4.25 installation running fine, changed my /.boot with “/bin/Fsys.atapi fsys -Ndsk0 -n0=hd0. -n5=cd0. atapi”…
No Fsys.eide needed anymore.
My BIOS “finds” 2. disk (80 GB SATA on IDE channel 2 master), QNX does not provide me with a new device!!?
Chipset Intel 82801EB should be supported (according to list)
Any hints?

Should probably be setup on channel 1.

Although the chipset is said to be supported, this is I think actually a feature of the BIOS. The BIOS must activate and support ATA register set emulation.

Yes, you´re right - as soon as we disconnected the CD-ROM, the disk was “visible” and could be accessed!
Got everything on the disk… /.boot on new SATA disk (partition 1 type 77, cylinder 0-2000=16GB) runs in new PC (HP DC7700)… does not boot though - Fsys.atapi got startet, the mount -p fails. Do I really need to go through the process of the installation of QNX on a “mini-boot partition” (1024-cylinder story)?

  1. My experience with SATA under QNX4 is: your BIOS Setup SATA/PATA settings must be set to: Compatible mode (sometimes called Combined mode) - where only 4 disk drives are supported 2 PATA and 2 SATA. When there is also “SATA mode setting” item - this must be set to IDE mode.
    In that settings some MB support only certain SATA connectors (for example second and fourth - read your BIOS Setup Help fields or MB documentation).
  2. The most simple way - connect only CD/DVD drive to first PATA and the only SATA HDD to first (allowed) SATA port. Then install QNX4.
  3. If you don’t want to have troubles in the future (when re-making QNX boot images) - when your disk is greater then 8GB (1023 cylinders), create first (using fdisk / from QNX install floppy/CD) small 2-cluster (15MB) partition t78 (QNY), Save, Exit and then install QNX4 from CD to empty place of disk. Then use that small partition for booting QNX4 (only to store boot images, set it active).

ok, fantastic - worked…
Have a 80 GB SATA Disk, created in a PC with IDE+SATA. Now wanted to run that disk in a standard HP DC7700 SFF PC… the Intel chipset of the HP board does not seem to be supported (off course** :imp: ***).
Does anybody have any ideas, what brand and type of PC you can buy on the “market” today, that is compatible to this Fsys.atapi?
Preferably HP products… guarantee questions can then be dealt between the local supporter and our customers.

pfipa, we use DC7700 also, although the CMT version. You don’t need to use Fsys.atapi (as you found out it doesnt work anyway). Normal Fsys.ata works fine as long as you have enabled IDE emulation in the BIOS (the option is a bit hidden but i can drag it out for you if you want). After that all works fine, though be careful with your arguments to Fsys you will need to turn cacheing off in 4.25 if you want a filesystem that survives a power down.

sounds good - but why can´t I then not make a “normal” installation from CD, if ATA would work?
The BIOS shows IDE emulation…
This whole thing seems strange

It should look something like this
Device configuration
Hardisk - Sata 0
Emulation Types : Hard disk
Multisector Transfers: Disable
Translation Mode: LBA Assisted
SATA Emulation: IDE
SATA 0 and 2: Enable
SATA 1 and 3: Enable

Not sure which file system the CD uses… we make our own installation CD which uses Fsys.eide which works fine for boot purposes :slight_smile:

Now you totally lost me - I once (a year ago) tried to install QNX from the QNX-suite onto a SATA drive… did not work, the QNX reply was: → workaround…
Now you are telling me that it just works with Fsys.eide? Have to admit, that I did not even bothered to try thistime :unamused:
Would you suggest, that I retry the whole procedure ?

Yes, gubbe is right. SATA HDDs (providing BIOS is set to “PATA+SATA Compatible mode” and SATA is set to “IDE emulation” mode) work with standard Fsys.eide - I think in “Compatible+IDE” mode QNX doesn’t recognize that HDD is not IDE (but SATA).

Note: Don’t buy latest Intel 965 (Socket LGA775) chipset based machines/MBs. There is NO NATIVE PATA support in this chipset. MB manufacturers add some “third party” PATA chips to their MBs (e.g. Jmicron, …) but they are not NATIVE (they need drivers).
Mostly you can recognize non-native PATA connectors by color - native PATA connectors are black or blue, non NATIVE are yellow, orange, …

If you don’t have native PATA, you cannot install QNX from ATAPI CD/DVD drive. Even if your QNX CD boots from non-native PATA connected CD/DVD, further when installation begins, it cannot recognize CD/DVD drive.

If you want Core 2 Duo CPU, buy older Intel 975 chipset based machine/MB. Intel 975 chipset includes native PATA.

But first of all - think in advance (before buying machine/MB) about graphic chipset - most of todays graphic chipsets (integrated or AGP cards or PCI-E cards) ARE NOT supported not only in QNX4/Photon but also in QNX6.
There are some supported in “latest” updates - e.g. ATI Radeon 7000 - 9800, Mobility Radeon M6, M7, M9 and the “newest” PCI-E Radeon X300, X300SE, X550 (X550 requires adding the new line with VendorID+Device ID (use show_pci to find them) to crttrap.list file), X600.

The same situation is with Ethernet chipsets (most of todays integrated chipsets is not supported) - but you can add some PCI card (e.g. Realtek 8139D, digital 21X41, Intel PRO, … chipsets).

Yes if you configure the bios correctly it should work, You need to use the IDE emulation feature in the dc7700. Did you try it?

BIOS is on Emulation “IDE” per default. I have Fsys.atapi running now - do you suspect Fsys.eide working “better” than Fsys.atapi?
Fsys.atapi does not work! Chipset seems to be Intel 965Q… not a “identification” that would link to any of the
supported chipsets of the official QNX articles… Since I have to find a solution, how should I proceed? New suggestions on hardware or different
installation procedure are very welcome and will be tried out :smiley:

The option is SATA Emulation: IDE, you mean to say that you couldn’t boot with Fsys.eide and those settings, thats very strange because it works fine for us and the DC7700. Did you rebuild your .boot ?

I just can not believe, I got through everything above… and the solution is just there… I tried a new disk in the new dc7700 and the QNX installation suite - and:
Surprise, it just initialized the disk…
I could bite myself for not trying before and following:
Thanks for “opening” my eyes :smiley: