inetd won't start

Hi all,
I run neutrino 6.3.0 sp3, made ftpd running by unquoting it in inetd.conf, it worked, then made Phindows running, it worked, then installed samba from the 3rd party cd, did some editing in inetd.conf… and now inetd won’t run at all anymore, not even after quoting out the samba lines and the phrelay line.

When I type “inetd” in a shell, the prompt comes back nicely, but no process is started, when I do that logged in as a differtent user, and use “su inetd”, I need to put in a passwd and then I get: “sorry”
Any suggestions?

Check syslog for any messages that might explain why.

mv inetd.conf as inetd.conf_ and see what happen

yep, I remember now I had this problem before… did not make a note.
can start inetd now, and indeed no services I unquoted: there was someting with a hidden inetd.conf copy and user-rights?

syslog showd some syntax errors: after removing a few empty lines it stops giving me errors. But inetd still does’n start, at least I cannot find it in the system monitor, nor does ftpd or phindows work.
Any thoughts?

I solved the problem, booted from the live cd and copied the inetd.conf from live-system to harddrive. I still don’t understand what happened, all rights seemed to be in order, could not find any spellings that were wrong in the old file, but now it works again, and I have a security copy of inetd.conf stashed in a corner.
Thanks for the help.

Now having inetd.conf, type this, being root:

  1. echo “swat stream tcp nowait.400 root /opt/sbin/swat swat -aâ€

and then I have Swat running, isn’t it? Were is the nowait.400 for?

swat is a web-based configuration utility( server as well) for samba server.
Once the request through TCP comes on port 901, inetd will launch it. You might use it to customize your samba server.
But to have running samba you should start it!!!

Here are the instructions how to install Samba on QNX63.
Prerequisite check:

  • Login in Photon as root
  • QNX system is connected to Ethernet
  • QNX system has assigned valid IP address. Check it using “ifconfig en0â€

Hmm, that’s a very nice piece of advice, thanks. I allready have it running a little though, allthough my netbios name is not found on the net yet, I’ll look into that later.
A while ago (actually a few years, running samba on my Amiga 4000T, to pump videofiles from pc to amiga back and forth…) Swat really made a mess of my little samba.conf, but now it stays very neat, that’s nice, I’ll use Swat now.
ok, I’m going to open a new topic on pureftpd, got a strange problem there.