debugging images

ok, I have this x86 qnx image on flash but it doesn’t boot properly.

When I start the pc it will ask for the partition to boot, which in my case would be the t79 one. The it would display “altboot…” and just hang there.

Does any one know how to debug this and find out what’s wrong??


now I try a boot image . It can boot normal!
but I don’t know your question.
please send more information!

yeah, maybe that wasn’t very clear…

Let me make it more clear, I made a QNX6.3sp3 image and put it on a compact flash card. I’m using this card with an IDE compact flash adapter so the device looks like a normal IDE drive. The computer is an intel 965RY chip set socket 775 duel core2. When I boot the machine off the flash it hangs on altboot or says missing operating system. However when I tried the same flash on an older machine (not sure of specs but a few years old) it boots fine and got to the qnx shell.

I’m not sure what is wrong as the image is fine and boots correctly on a different machine, the duel core machine is also fine since it runs linux fine off the harddisk. I’m thinking it’s some issues with the mother IDE controller?? but I’m not sure, how can I debug and find out what’s really wrong?? I’ve tried change various bios settings but they don’t help, formatting the flash a few times and reloading the image does the same.

I’m running out of ideas.

If it display only a few dots then it’s the loader that can’t load the image. This is usually done through BIOS calls so there is no issue with QNX drivers incompatibily. However if the flash card was setup on a different machine and the BIOS used a different disk geometry then the BIOS on the computer you are trying to get this running that would explain the problem you are seeing.

The strange thing is I made the image on the core2 machine and it works on 2 other different machines, but not the original machine. I also tried it on a Dell optiplex GX280 and it also does not work. The 2 machines that worked are old and only have IDE were as the 2 newer machines both have SATA.
I used a smaller fash (512 rather than 1G), and it also shows similar problems. The smaller flash displays altboot then stops and the 1G displays missing operating system. Seems like qnx does not like the newer machines for some strange reason.
I’ve asked around the office here and one suggestion is that it might be like a linux problem where it cannot locate the device, and apparently the solution is to bootstrap using a usb stick, problem is I have no idea how this could be done with qnx.

I did some more tinkering and thing just get more strange.

It seems that qnx on flash does not work properly on intel ICH chips.
I’ve tried it on:

  • 82801GB
  • 82801FB
  • 82801EB (this one gets to altboot but then freezes)
  • 82801HB (this on is not on the supported ICH list)

The only computer that booted was one not using an intel south bridge.

  • VT82C686B

Anyone out there have similar problems? or can suggest something? I’m running out of ideas…