compact flash image does not boot

I’ve posted this under the help forum, but didn’t get much responses so I’m reposting here…

basically I’m using an IDE-CF adapter and I want to boot off a compact flash using it. I have a very basic image, just a shell. The problem is that the compact flash does not boot. I’m getting errors like “missing operating system”, “disk error” or hangs on altboot.

These errors are different depending on the PC I use to boot.
The flash does not work properly on PCs with intel ICH chips.
I’ve tried it on:

  • 82801GB
  • 82801FB
  • 82801EB (this one gets to altboot but then freezes)
  • 82801HB (this on is not on the supported ICH list)

The only computer that booted was one not using an intel south bridge.

  • VT82C686B

Has any tried a similar thing or have similar problems like this before?


First question: Which version of QNX?

Second question: How’d you make the CF image?

Generally, a CF plugged into an IDE adapter should function EXACTLY like a hard drive.

You can see my earlier posts for copying a hard drive, which includes the partitioning, boot loader, etc. instructions. I’ve also previously pointed out the importance NOT overwriting .inodes and .bitmap, and the fact that you MUST manually overwrite .boot and .altboot.

With more information we might be able to provide more help.

-James Ingraham
Sage Automation, Inc.


Version: QNX 6.3 sp3
Image: the image was from another project known to be working. I recompile it using the IDE bundled with qnx.
Here what I did:

  1. compile image… no errors
  2. format using fdisk, 2 partitions, t79 (marked as boot and loader, about 20MB) and t77 (about 1.9G)
  3. the I did dinit to the t77 partition, copied over the file structure (/bin, /etc, /opt …etc)
    4 and then dinit -h -f with the image on the t79
  4. then rebooted.

on the machine with the VT82C686B south bridge the image loads and the shell is started, can’t do anything in the shell because I didn’t put any binary or setup paths or library …etc BUT it loads. The other machines I used the same method, but does not work. One gets to altboot with the dots and then freeze, the others give various errors either “disk error” or “missing operating system”

I haven’t tried building a fresh image using the IDE tool, because I don’t know how the boot scripts work yet.