how do i copy from one flash to other

hi dear all,

iam a new bee to QNX and iam facing a problem i have two flash disks of different manufactures but of same memory size.

when i tried to make a ditto copy of it using

cp -V dev/hd0 dev/hd1

it give the second flash has run out of memory thou i the contents iam copying is only of size 61Mb.
i even tried with

dd if=/dev/hd0 of=/dev/hd1

it copied but when i tried mounting it with mount -p it says no space for partitioning.

plzzz help its urrgent. egarly waiting for responce.

Hmmm, this problem seems to be an all time favorite. ;-)

look here:
or here: … ght=#32622

Extract: Partition and format the new flashdisk and copy all files to it and update the licenses if necessary.


i have done that thou didn’t think about licenses as it was in the new style.

but still it is not booting up.

Can you mount the second flash drive?

i tried mounting it but when i mounted it it says

i,e when i tried doin

#mount /dev/hd1t77

it says no space for partition . what shud i do.

Is that a typo? You need to specify where to mount it.

mount /dev/hd1t77 /flash

ya i did specify it sorry for not including it in there

dear friends,

as i have told you in the pervious mails.iam not able to mount the flash.

the acutual problem is the 64Mb flash is showing only 61Mb i don’t know what happend to the other thee due to which iam facing problem.

and i have one moeer problem the original flash of which i don’t have any backup is also not mounting now. it says

" there is NO BIOS on it" I didn’t understand what happend and y iam getting that. can anyone plz help.

and is there any way in which i can make my original flash work.

iam at point blank if the original flash does not work iam dead. plz help

plz help.

thanks in advance and waiting for the reply.

hello frd’s,

is thr no one who can help me retrive the data from the original flash. plz help

with due regards

Please discribe your harware setup.
What is the system (PC?)
How is the compact flash connected? (pcmcia, eide?)
How are yo starting the eide driver? (automatically / manually?)

iam working on a Single board computer (SBC) which has a flash disk of 64MB connected as EIDE as its hard my company we were using this to run a system for some application. now my company wants to upgrade this to a desktop pc and run the application on it. and the person who had developed this system has deleted the source for some reason now we are left with only this working system and have to retrive the EXE of this and make it work on the new desk top PC.

so what i had planned was to first make a copy of this into a new flash so that we don’t corupt the original and in the process the original also got corrupt and we don’t have any backup of this and iam also not able to make a copy on to the new flash as i had said earlier.

what shud i do make my original flash work or make a copy of it on to the new flash so that it worrks .

waiting for the responce and thanks in advance plz help

My suggestion:
If you can, connect a normal hard disk to the system and connect the compact flash to the second EIDE channel. If you have no second EIDE interface, try connecting the compact flash (CF) to the same channel as a slave.
Install QNX on the hard drive.
This may be tricky, I have no idea what your hardware looks like or what interfaces it has.

Boot the system from hard disk.
The CF should now be present as a second device
/dev/hd0 - the hard disk
/dev/hd1 - the CF
and hopefully /dev/hd1t77

Now you may be able to view the contents of the CF, if you are lucky it will be mounted as /fs/

if not, try mounting it manually: mount /dev/hd1t77 /fs/cf

If this works, I suggest you copy the contents of your original CF to the hard drive, you now have a backup.

I have done this on a few projects and ALWAYS found it best to create a CF from scratch,

  1. fdisk
  2. dinit
  3. copy contents to the disk.

The internals of a CF vary between manufacturers, they are designed to go into digital cameras and mp3 players, not to boot embedded systems (at least not any more).
Even Sandisk have stopped producing the industrial grade CF.

There are a few tricks you may have to use to get the CF to mount correctly, look into the docs on devb-eide for options on NON_REMOVABLE and NO_PTAB, I can’t remember which modules they apply to (io-blk or eide) you need to read the documentation to understand these.

Try these ideas and post your results.
Good luck…

thanks for the reply i did mount the Compact flash as told by you and was also able to make a copy of the flash on to the hard disk using

cp -V /source /desti.

but now the problem iam facing is in this process of copy some file went missing from the original compact flash and it is not mounting as i was not able to see hd1t77 partition when i connected so i tried doing

mount -p /dev/hd1

it give error as No BIOS signature found on the /dev/hd1.

what might be the problem or which files are missing do you think.

what shud i do to recover the original flash and make it work.

thanks again for the reply

So you have your embedded PC booted from a hard disk?
The original CF is connected ?
You have an entry in /dev/hd1
Do you have /dev/hd1t77 or /dev/hd1t78 or /dev/hd1t79 ?
If the original CF is not mounting, how did yo make a copy?

when i first connected it did mount and i was able get that /dev/hd1t77

but once i copied that as an image of CF to the hard disk then later on its not mounting .

it gives No BIOS signature found on /dev/hd1.

let me give in detail

  1. first i disconnected the CF from the board and connected it to the system (PC) booting from its hard disk.

  2. it identified the CF as hd1 along with its partitions i.e

  3. i mounted it as mount /dev/hd1t77/ /CF.

  4. made a image of it on the hard diak using

    cp -V /dev/hd1 /copy/new

5 ) un mounted the original CF and connected the new flash disk of same size and make as /dev/hd1t77 /newCF. and tried copying in to it using

cp -V /copy/new /dev/hd1

it could not copy in to the new CF with some memory problem.

  1. then reconnected the original flash to the PC and tried mounting. but this time the CF was identified as /Dev/hd1 but its partitions never appeared so tried mounting it using

mount -p /dev/hd1

when i typed it it say " NO BIOS SIGNATURE FOUND ON /dev/hd1"

  1. now i want to recover the original CF and make a copy of it to the new flash iam stuck at this point. plz help.

i even tried using disk copy

dd if=/dev/hd1 of=/dev/hd2 connecting both the flash disks together but was of no use.

You cannot hot swap CF disks on the EIDE interface.
CF disks are in theory hot swapable, but the EIDE interface is not.
You MUST power down to swap the CF.

If you do this I think you will have better luck.