Mouse and Keyboard problems.

I’ve decided to try out the QNX 6.3 evaluation kit on my PC. I’ve previously run QNX 6.2 NC successfully on the same machine.

I’m having a problem: once the GUI starts, the keyboard stops working, the mouse also does not work. The keyboard is PS/2 and the mouse is a USB mouse using a PS/2 adaptor, both connect via a KVM switch.

The only error message I get during the boot is a ‘Resouce denied: Invalid Argument’ (or something of the sort, I’m going from memory), and trying ESC for alboot seems to make things freeze up.

Does anyone have any tips?

I see this problem quite a bit.
The kvm switch and the PS2 port are not compatible.
Not sure why or in what way, if your KVM has an activity LED, I bet it flashes periodically, even with no keyboard or mouse actions.

The only work around I can suggest is to use a seperate mouse, a pain I know, but it works.

Some PS2 ports are not fully supported by the QNX driver, so a mouse and keyboard connected via a splitter cable to the same port does not always work either.


I think the problem is that Photon (or rather the devi-hid driver) no longer supports PS/2 in QNX 6.3. It only works with USB keyboards and mice.

I can’t exactly remember where I saw this in the doc’s (might have been in the 6.3 readme notes). Maybe someone who does remember can comment on it. But if you do a ‘use devi-hid’ is says it’s specifically for USB only.

So your going to have to use a USB keyboard/mouse if you want to use the GUI. If you turn photon off, then you can use PS/2 input devices.

You should be able to very cheaply buy PS/2 to USB converters assuming your PC has USB connectors so you can continue to use the KVM setup you have.


Uh, I’m going to have to disagree with that. I have about a dozen 6.3 systems, all with PS/2 keyboards working just fine in Photon. The newest have USB mice now, but the older ones have PS/2 and I have at least four systems with serial(!) mice working in Photon.

Also, last I heard there is no way to use a USB keyboard if you boot to a terminal instead of Photon. That information may be out of date, but that’s the reason all of our systems use PS/2 keyboards.

-James Ingraham
Sage Automation, Inc.

Thanks for all of the replies, even though they bring me no closer to a solution. I check the disk to see if I can find the readme files.



We have some Blade computers here and they have PS/2 and USB connections. I’ve tried installed 6.3 SP3 on them and while the install is running the PS/2 stuff works. But the instant photon starts (on the boot after install) the PS/2 stops working.

Now it always worked prior to SP3. But since I started using the SP3 full install I can no longer get PS/2 working in Photon no matter what I do.


Odd. Perhaps the input. file? I had some issues prior to SP3 where we would copy a drive and change the node name, and the keyboard would go screwy until we changed the input filename to match the node name. With SP3 we’re running without an input. file at all.

-James Ingraham
Sage Automation, Inc.


It could be the input file. I didn’t explore in more details because PS/2 is a dead technology anyway and I’d prefer to use USB.

But I believe this is what’s causing John’s problem too since his PS/2 devices stop working the instant photon starts.

He’s either going to have to get a PS/2-USB converters (about $5) as I suggested or poke around with the input file and see if he can get it to work.


We are using default SP3 installs and PS/2 works fine always. Mouse and Keyboard are running with PS/2.
I had some issue getting USB to be supported during Installation, but thats all.


Are you booting into Photon or just the command console?

If you only boot to the command console (you do the .nophoton thing) then PS/2 works (or it does for me).

I suspect there must be some kind of option you can pass to io-hid and devi-hid to make PS/2 work. But as I said, the default 6.3 SP3 install definitely 100% doesn’t work with PS/2 on any of my machines.