Does anyone know of a USB Ethernet Adapter that works with QNX 7.1 using the driver?

Have you asked QNX support ?

No, I don’t have a QNX support contract.

I can ask them if you want.

The above discussion from 2019 says Ralink USB WiFi works in 6.5 so presumably it works in 7.1 as well since I doubt support ever gets dropped for older hardware. Of course this is WiFi which you may not want.


I bought a cheap device that will come in a day or so. I’ll see if that works first.

Thanks, I will take a look if I need to. This is a one shot for development so as long as it works I’m fine with it.

OK. No problem.

This line is just to have at least 20 characters to be able to post :wink:

I’d now like to take you up on your offer. The 2nd device is definitely USB Ethernet Class and does not work with it. I tried all three listed protocols in the documentation. There is another driver that doesn’t seem to do anything.

There’s a little more to say. I discovered that creates a network device whether the usb is plugged in or not. The does not.

The usb command shows the device as an Ethernet 10/100 device. There are other parameters that don’t seem to make sense, e.g. busnum, devicenum. There are no busnum, devicenum values visible from the usb command. This is all very confusing.

I’ll ask QNX support. Which architecture are you using ? x86, x86_64, ARM, ARM64 ?

There’s a little more to say. I discovered that creates a network device whether the usb is plugged in or not. The does not. is to be used on the host side, to use a USB to network device. is to be used on the device side, to create a USB to network adapter.

So, in your case you need to use

Thank you. I haven’t see that anywhere in the documents. It does make sense now that devnp-usbdnet includes a (USB-ETHERNET) protocol option, but devnp-usbnet doesn’t.

Knowing that I can ignore the usbdnet version I’m going to give it one more try. however my experience has been that running the usbnet driver I see nothing when I plug in the USB device. I tried this on both QNX 6.5 and 7.1. On 6.5 I wrote a simple program to detect insertion, and guess what? I detect insertion.

I’ve tried starting the driver before and after insertion with the same negative results. If I manage to figure anything out I’ll report it back here.



I think all that devnp-usbnet does is start a very basic hardware driver. You still need to start io-pkt and then a specific driver for your USB hardware which you don’t have. I base this off these doc’s

The Kawasaki Ethernet driver.

You really do need a list of supported hardware which it’s a shame QNX 7 doesn’t have like the old 6.5 and earlier did on their website.



I’ve been starting the driver with io-pkt. I would find it strange if there needs to be another driver. Many QNX USB drivers such as keyboard and mouse are USB “class” drivers. there is a specification for a USB-Ethernet class. In addition, I believe that is what both my USB hardware devices are. They didn’t need manufacturer specific drivers.

The Kawasaki driver you are pointing to is an older io-net driver. There was a devnp bridge driver that worked with io-pkt but could use io-net drivers. I don’t think that is what I’m looking for here. I’m going back to the drawing board to play around a little now that I know that is not what I’m looking for.


I’ve asked QNX support.
Here are some additional information :

  • is to be used with USB network devices that support NDS, RNDS, NCM… Using this driver, you should be able to connect to a Windows or Linux box directly.
  • The recommended driver is It supports USB Ethernet dongles with ASIX AX88172, AX88172A, AX88178, AX88772, AX88772A, AX88772B chips.
  • The driver supports SMSC 9500, 9500A, 9514, 9530, 9730, and 89530 USB Ethernet dongles.


Thanks for this info! It’s exactly what should be more widely available.

It’s clear that is NOT a general solution to use Ethernet (surf the web, use SSH etc) but rather a specific solution to talk directly to a Windows or Linux machine. No wonder Maschoen couldn’t figure it out.



Sure. Far from obvious.


Well this is what I needed to know but is still very confusing. I’ll see if I can fight my way through it.

Thank you both