Strange hanging (blank screen) after "Hit Esc for alternate OS........"

Hello QNX friends. I am servicing our very old SCADA application running under QNX 4.25H on old Industrial PC (Advantech PCA-6159L Pentium MMX All-in-one SBC, WD40GB IDE HDD). Boot process “hangs” immediately after “Hit Esc for alternate OS…” when QNX OS “begins to talk” with the hard disk. Monitor goes to blank (black) screen or “No input signal” monitor popup (depending on Power Saving method set in BIOS Setup; but even if the Power Saving is completely Disabled in BIOS). If I press ANY key on the keyboard, the screen “comes back” and the boot process continues.
If I enter the altboot by pressing key, everything works OK (because I pressed the key). I have classic PS/2 keyboard and classic PS/2 mouse. It seems that the PC enters some power saving mode when the OS image “starts to talk” with the hard disk (initializing the disk?) I’ve never seen that before.

I tried:

  • everything (I think) in BIOS Setup of the PC,
  • other PS/2 keyboard,
  • other All-in-one SBC of the same type PCA-6159L (the only I have here),
  • other EIDE hard disks (always fresh install of everything on another PC with bootable CD drive),
  • other PCI graphic card, same type and other type (S3 Trio 64, ATI Rage),
  • other (new) power supply,
  • Fsys.atapi, Fsys.eide and Fsys.ata based QNX boot image.

Have you ever seen that? Any advice? Maybe some parameters in Fsys.atapi (or Fsys.eide) or?

Did this used to work before on this PC?

It sounds to me like the O/S is hanging at boot time which is why the monitor goes into sleep mode.

When you hit ‘esc’ for the alt O/S does it boot correctly? If so, that would seem to say that the diskboot is working (that’s likely what the alt O/S uses) and diskboot interrogates the hardware before starting the right driver. I suspect your primary boot is crashing somehow when trying to start the hardware. That’s why I asked if it used to work on that PC.


We have used the Advantech PCA-6159L All-in-one SBCs a lot of times for our systems and I’ve never seen this problem before. Now - two pieces of Advantech PCA-6159L SBCs (one of which has newer BIOS - supports HDDs > 32GB and also boot from CD-ROM) behave the same.

Yes, I think that the monitor blank screen (or no input signal and amber LED) is only the consequence of a kind of “halt” (pause?) status of the PC when QNX is initializing hard disk.

Altboot works OK, because you should press Esc key and that’s why PC continues (from the “halt” status).

I even tried installing another HDD (only 20GB) directly in that PC (I managed to boot from QNX installation CD finally due to newer BIOS in the other All-in-one SBC, which supports boot from CD already). And immediately after QNX installation - the first restart after removing installation CD from optical drive - boot “hangs” when initializing HDD. After pressing any key - continues OK.

You might want to contact Avantech and ask them about this (the change in BIOS for that machine). They are a recognized QNX partner (we buy our machines from them for QNX 7) so they would understand getting questions about running QNX on their machines.