Using MPUT to transfer directory or files

Hi, I’m trying to move a directory from a QNX 2 pc to a windows pc using a crossover cable. I guess I have forgotten some FTP stuff. I’m using MPUT. Any help ?

Ok, so I guess you can’t, so I’m trying to send the contents of the directory with MPUT but I get a “Arguments too long” message. I think I ran into this a long time ago. Was there a command “ULIMIT” that had to be increased? Thanks, I’m going home. boy this new forum format sucks.

TCP/IP on QNX 2 was rare. I recall at least two implementations. Both were not very good. When you say a crossover cable, I’m a little confused. Serial? I don’t recall any QNX TCP/IP that would go over serial. 10T? I don’t recall any of the supported cards using 10T. It was a coax world back then. Coax Cable? No such thing as a crossover.

An alternative route if you have floppy disk drives, disks and the dfs (Dos File System) software would be to do a floppy shuffle. Outside of that you could try to dig up a DOS program that supports xmodem. I believe that the QNX qtalk program could support it.

No, it’s ethernet RJ45. There is a data acquisition app that runs on the pc that has it.

How many files are you trying to transfer in that directory?

The ‘arguments too long’ message typically happens if you have too many files and it exceeds some predefined limit (which on QNX2 is likely to be a lot smaller than you think).


I tried it with 1 file and no good. But PUT works.

ps Actually new forum is ok. I must not have had popup blocker on at other pc.

I tried it with 1 file and no good. But PUT works.

No, it’s ethernet RJ45. There is a data acquisition app that runs on the pc that has it.

Have you taken a look at the directory names and file names to be transferred? QNX2 allowed some names that might not be legal in Windows so it’s possible mput is failing because of a bad file/directory name.

The other option is to try going the other way and doing an mget from the Windows side to see if it gives you more information on where it’s failing.

There is also ASCII vs binary mode too. Are you only transferring text files?


Yup I tried MGET from the Windows pc. It makes the connection and then shuts down the connection with a message saying that. I’d have to try it again when I get back to see what the exact message was. I was using Binary. Maybe I’ll try ASC tomorrow night.

I held down a key on the command line. It stopped, and I counted 255 characters. It works if you have less than 255 characters.

This is not at all unexpected. QNX 2 was written in the mid 80’s and was first able to run on an IBM PC with 64K of ram. You might expect that the limitations might be a bit tighter than today’s OS with Gigabytes of memory.

Is there a way around this limitation? I sure would like to be able to transfer directories or their entire contents to another pc, with FTP.

You could put the directory into an archive file. There was at least one archive program on QNX 2. I think it was a port of an open source program.


Trying to use zoo, to archive a directory’s contents, including subdirectories. Can’t get it to work. It got some of the files. Does anyone know the commands to do this? There is also Archive.